Ir al contenido principal
BlogSeguridadLinode Security Digest 13 - 20 de enero de 2023

Linode Security Digest del 13 al 20 de enero de 2023

Linode Security Digest

En el resumen de esta semana hablaremos de lo siguiente:

  • Apache Vulnerabilidades del servidor HTTP;
  • una vulnerabilidad de desbordamiento de enteros en el Netfilter del núcleo de Linux; y
  • CentOS Panel Web 7 RCE

Apache Vulnerabilidades del servidor HTTP:

  • CVE-2006-20001 - mod_dav lectura o escritura fuera de límites de byte cero

Si una cabecera de petición cuidadosamente elaborada puede realizar una lectura o escritura en memoria de un único byte cero en una ubicación de memoria heap más allá del valor de cabecera enviado, podría provocar el bloqueo del proceso. Este problema afecta a Apache HTTP Server 2.4.54 y anteriores, así que actualice a 2.4.55 para mitigarlo.

La interpretación incoherente de las peticiones HTTP ('HTTP Request Smuggling') vulnerabilidad en mod_proxy_ajp de Apache HTTP Server permite a un atacante contrabandear peticiones al servidor AJP al que reenvía las peticiones. Este problema afecta a Apache HTTP Server 2.4 versión 2.4.54 y versiones anteriores, por lo que debe actualizarse a 2.4.55 para parchear esta vulnerabilidad.

  • CVE-2022-37436 - mod_proxy anterior a 2.4.55 permite a un backend activar la división de respuestas HTTP

El software no procesa correctamente las secuencias de caracteres CRLF, que son caracteres de fin de línea. Los atacantes pueden enviar un paquete HTTP crafteado con una secuencia CRLF, provocando el truncamiento anticipado de las cabeceras de respuesta e incorporando algunas cabeceras al cuerpo de la respuesta. Si las cabeceras posteriores tienen algún propósito de seguridad, no serán interpretadas por el cliente. Este problema afecta a Apache HTTP Server 2.4.54 y versiones anteriores, así que actualice a 2.4.55 para parchear esta vulnerabilidad. 

Vulnerabilidad de desbordamiento de enteros en Netfilter del núcleo de Linux

CVE-2023-0179 consiste en un desbordamiento del búfer de pila debido a una vulnerabilidad de desbordamiento insuficiente de enteros dentro de la función nft_payload_copy_vlan, que se invoca con expresiones nft_payload siempre que haya una etiqueta VLAN en el búfer del socket actual. RedHat dio a esta vulnerabilidad una puntuación CVSS v3 de 7,8, que afecta a máquinas que están en las versiones más recientes de la distro como Ubuntu Jammy, Debian Bullseye, Rocky Linux 9, o máquinas con un kernel versión 5.10 LTS. Esta vulnerabilidad no afecta a Debian buster. 

Mitigue este fallo deshabilitando los espacios de nombres de usuarios sin privilegios para evitar su explotación:

sysctl -w kernel.unprivileged_userns_clone = 0

Centos Vulnerabilidad de ejecución remota de código en Web Panel 7

CVE-2022-44877 is a critical vulnerability that affects any CWP below version 0.9.8.1147 and is being exploited in the wild. This vulnerability exists in the login/index.php in CWP and allows remote attackers to execute arbitrary OS commands via shell metacharacters in the login parameter. Researchers released a PoC for this vulnerability to GitHub and Youtube on January 5th, 2023, leading to increased exploitation by threat actors. To mitigate this threat, update to the latest version, v0.9.8.1148, as this affects Centos Web Panel 7 < v0.9.8.1147.


Comentarios

Dejar una respuesta

Su dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *.