tumbledown

by mysterium
60 deployments · 60 still active · last rev. 1 month ago

Compatible with: Ubuntu 16.04 LTS
						#!/bin/bash

# Initial updates
apt update -y
DEBIAN_FRONTEND=noninteractive apt-get -y -o Dpkg::Options::="--force-confdef" -o Dpkg::Options::="--force-confold" upgrade

apt-get update && apt-get install -y git-core libgnutls28-dev lua5.1 liblua5.1-0 liblua5.1-0-dev screen python-dev python-pip bzip2 zlib1g-dev flex autoconf

pip install --upgrade seesaw
cd /root
git clone https://github.com/ArchiveTeam/tumblr-grab.git
cd tumblr-grab
./get-wget-lua.sh
screen -d -m -S tumblr
screen -S tumblr -X stuff 'run-pipeline pipeline.py --concurrent 20 jtag'$(echo -ne '\015')