Ubuntu 12.04 - Ruby 1.9.3

by birarda
8 deployments · 1 still active · last rev. 4 years ago

Nothing special.
Builds Ruby 1.9.3 from source to prepare the VPS for a bootstrap via chef.

Compatible with: No distros currently supported
						#!/bin/bash

apt-get update
apt-get -y install build-essential zlib1g-dev libssl-dev libreadline-dev libyaml-dev libcurl4-openssl-dev

cd /tmp
wget ftp://ftp.ruby-lang.org/pub/ruby/1.9/ruby-1.9.3-p194.tar.gz
tar -xvzf ruby-1.9.3-p194.tar.gz
cd ruby-1.9.3-p194
./configure --prefix=/usr --disable-install-doc
make
make install