跳到主要内容
博客安全问题Linode安全摘要 2023年1月13日至20日

2023年1月13日至20日Linode安全摘要

Linode安全摘要

在本周的文摘中,我们将讨论以下内容:

  • Apache HTTP服务器的漏洞;
  • 一个Linux内核Netfilter的整数溢出漏洞;以及
  • CentOS Web Panel 7 RCE

Apache HTTP服务器漏洞:

如果一个精心设计的请求头可以在堆内存位置执行超出发送的头值的单个零字节的内存读取或写入,可能导致进程崩溃。这个问题影响到Apache HTTP服务器2.4.54和更早的版本,所以要升级到2.4.55才能缓解。

Apache HTTP服务器的mod_proxy_ajp存在不一致的HTTP请求解释("HTTP请求偷渡")漏洞,允许攻击者将请求偷渡到其转发请求的AJP服务器。这个问题影响到Apache HTTP服务器2.4版本2.4.54和之前的版本,所以升级到2.4.55来修补这个漏洞。

  • CVE-2022-37436 - 2.4.55之前的mod_proxy允许后端触发HTTP响应分割

该软件不能正确处理CRLF字符序列,这是行末字符。攻击者可以用CRLF序列发送一个精心制作的HTTP数据包,造成响应头的提前截断,并将一些头纳入响应体中。如果后面的头信息有任何安全目的,它们将不会被客户端解释。这个问题影响到Apache HTTP服务器2.4.54和之前的版本,所以升级到2.4.55来修补这个漏洞。 

Linux内核Netfilter整数溢出漏洞

CVE-2023-0179 包含由于 nft_payload_copy_vlan 函数中的整数下溢漏洞导致的堆栈缓冲区溢出,该漏洞使用nft_payload表达式调用,只要VLAN 标记存在于当前套接字缓冲区中。RedHat 给这个漏洞的 CVSS v3 评分为 7.8,这会影响使用最新发行版的机器,例如 Ubuntu 贾米, Debian Bullseye、Rocky Linux 9 或内核版本为 5.10 LTS 的计算机。此漏洞不会影响 Debian 克星。 

通过禁用非特权用户名称空间来缓解这一缺陷,防止利用:

sysctl -w kernel.unprivileged_userns_clone = 0

Centos Web Panel 7远程代码执行漏洞

CVE-2022-44877 is a critical vulnerability that affects any CWP below version 0.9.8.1147 and is being exploited in the wild. This vulnerability exists in the login/index.php in CWP and allows remote attackers to execute arbitrary OS commands via shell metacharacters in the login parameter. Researchers released a PoC for this vulnerability to GitHub and Youtube on January 5th, 2023, leading to increased exploitation by threat actors. To mitigate this threat, update to the latest version, v0.9.8.1148, as this affects Centos Web Panel 7 < v0.9.8.1147.


注释

留下回复

您的电子邮件地址将不会被公布。 必须填写的字段被标记为*