apache2 ssh config issues

I have a linux machine.

Apache2 was already installed on it.

Got a linode. Ran through tutorials on setting up ssh on machine. Made users. Using a not user ssh i installed apache2. All kinds of config issues and apache is not running at all. Did I mess up by installing apache2 in my ssh when I already had apache2 installed on my root linux??

Not sure what I'm doing:

[email protected]:/etc/apache2/sites-available$ ls
000-default.conf  chrisbodnarchuk.com.conf  default-ssl.conf

[email protected]:/etc/apache2/sites-available$ service apache2 reload
Failed to reload apache2.service: The name org.freedesktop.PolicyKit1 was not provided by any .service files
See system logs and 'systemctl status apache2.service' for details.

[email protected]:/etc/apache2/sites-available$ systemctl status apache2.service
● apache2.service - LSB: Apache2 web server
 Loaded: loaded (/etc/init.d/apache2; bad; vendor preset: enabled)
  Drop-In: /lib/systemd/system/apache2.service.d
   └─apache2-systemd.conf
Active: failed (Result: exit-code) since Fri 2017-09-01 12:01:01 CDT; 6min ag
Docs: man:systemd-sysv-generator(8)
Process: 4048 ExecStart=/etc/init.d/apache2 start (code=exited, status=1/FAILU
lines 1-7/7 (END)...skipping...
● apache2.service - LSB: Apache2 web server
Loaded: loaded (/etc/init.d/apache2; bad; vendor preset: enabled)
Drop-In: /lib/systemd/system/apache2.service.d
   └─apache2-systemd.conf
 Active: failed (Result: exit-code) since Fri 2017-09-01 12:01:01 CDT; 6min ago
 Docs: man:systemd-sysv-generator(8)
Process: 4048 ExecStart=/etc/init.d/apache2 start (code=exited, status=1/FAILURE

When i run sudo service apache2 reload i get

apache2.service is not active, cannot reload.

Note - apache2 still runs in main linux users

1 Reply

On your linode server run the following command "systemctl start apache2" then run "systemctl status -l apache2" and post the output for both commands. If apache 2 fails to run the 2nd command should provide some clues to what is causing the error. Most likely cause is errors in your apache config files. you can run the command "apachectl -t" to check your configs for any errors. If that command returns "Syntax OK" then everything is good. if there are any errors they will be shown.

Reply

Please enter an answer
Tips:

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct