메인 콘텐츠로 건너뛰기
블로그 안전 Linode Security Digest April 24 – May 1, 2022

Linode Security Digest - 2022년 4월 24일~5월 1일

리노드 시큐리티 다이제스트

이번 주 보안 다이제스트에서는 중요한 Jira Security Advisory 및 Java 및 Kubernetes의 침투에 대한 기타 심각도가 높은 취약성에 대해 다룰 것입니다.nginx 모듈. 

JIRA 서버 및 데이터 센터 인증 바이패스

Atlassian이 4월 20일 발표한 보안 권고 에 따르면 일부 이전 버전의 JIRA 서버 및 데이터 센터는 인증 우회 취약점이 발생하기 쉽습니다. 이 취약점으로 인해 인증되지 않은 원격 공격자가 영향을 받는 구성을 사용하여 WebWork 작업의 인증 및 권한 부여 요구 사항을 우회할 수 있습니다. Atlassian은 이 취약점을 심각한 심각도로 평가했으며 특정 구성만으로 환경이 취약해진다는 점에 유의하는 것이 유용합니다.

영향을 받는 타사 및 Atlassian 응용 프로그램에 대한 자세한 내용은 권고를 읽을 수 있습니다. 이는 심각한 취약점이므로 Atlassian은 사용자가 패치된 버전의 Jira로 업그레이드하여 취약점을 수정할 것을 권장합니다. 

취약한 버전은 다음과 같습니다.

Atlassian Jira Server 및 Data Center 버전 8.13.18 이전, 8.14.0-8.20.6 사이, 8.21.0-8.22.0 사이

Atlassian Jira 서비스 관리 서버 및 데이터 센터 버전 4.13.18 이전, 4.14.0 – 4.20.6 사이, 4.21.0 – 4.22.0 사이

고정 버전에는 8.13.18, 8.20.6 및 8.22.0 및 4.13.18, 4.20.6 및 4.22.0이 포함됩니다.

자바의 심령 서명

타원 곡선 디지털 서명 알고리즘 (ECDSA)은 타원 곡선 암호화를 사용하는 디지털 서명 알고리즘이며 제대로 구현하기가 어렵다는 악명이 높습니다.

CVE-2022-21449 는 Java가 ECDSA 서명을 처리하는 방식에서 발견된 취약점에 할당됩니다. 코드베이스의 EC 부분은 Java 버전 15에서 다시 작성되었으며이 재 작성은 서명을 확인하는 동안 특정 검사가 수행되지 않는 버그를 도입했습니다.

서명된 JWT(JSON 웹 토큰 ) 및 기타 인증 메시지에서 ECDSA를 사용하는 경우 이 버그로 인해 공격자가 SSL 인증서와 핸드셰이크를 위조하여 서버에 자신을 인증할 수 있습니다. Oracle은 사용자가 취약성을 완화하기 위해 Java 설치를 최신 버전으로 업데이트할 것을 권장합니다. 15 이상의 모든 Java 버전이 영향을 받으며 Oracle이 릴리스한 2022년 4월 중요 패치 업데이트는 취약점을 완화합니다.

National Vulnerability Database에 따르면 이 취약점을 성공적으로 악용하면 중요한 데이터 또는 모든 Oracle Java SE, Oracle GraalVM Enterprise Edition 액세스 가능한 데이터에 대한 무단 생성, 삭제 또는 수정 액세스가 발생할 수 있습니다.

근본 원인

Java 버전 15에서는 처음에 C++로 작성된 타원 곡선 암호화 코드가 Java로 다시 작성되었습니다. 이 재작성으로 인해 ECDSA 서명을 사용하는 인증 메커니즘이 위조된 메시지 인증에 취약해졌습니다.

CVE-2022-21449에 대한 OpenJDK 취약점 권고는 여기에서 확인할 수 있습니다.

크레딧: 닐 매든

쿠버네티스 인그레스-Nginx 취약성

쿠버네티스는 사용자에게 침투-nginx 로드 밸런서 및 역방향 프록시로서의 모듈.

CVE-2021-25746 은 수신 개체를 만들거나 업데이트할 수 있는 사용자가 수신의 자격 증명을 얻을 수 있도록 하는 취약점에 할당됩니다.nginx 컨트롤러. 기본 구성에서 해당 자격 증명은 클러스터의 모든 비밀에 액세스할 수 있습니다.

A successful exploit by a malicious user could allow them access to every secret in the Kubernetes environment. This is a high-severity vulnerability that only affects Kubernetes users who use the ingress-nginx module (<1.2.0) in its default configuration. If you do not use the ingress-nginx controller, you are not affected, as per the security advisory. This vulnerability was mitigated by the 1.2.0 and v1.2.0-beta.0 version updates.

권고에 따라 수정 프로그램을 롤아웃할 수 없는 경우 metadata.annotations 값을 알려진 안전한 값으로 제한하는 승인 정책을 구현하여 이 취약점을 완화할 수도 있습니다(새로 추가된 규칙 또는 주석-값 -단어-차단 목록에 대해 제안된 값 참조).


코멘트

댓글 남기기

이메일 주소는 게시되지 않습니다.