Zum Inhalt springen
BlogSicherheitLinode Security Digest 1 - 7, April 2022

Linode Security Digest 1. bis 7. April 2022

Linode Security Digest

Diese Woche besprechen wir eine hochgefährliche Schwachstelle im Linux-Kernel, eine LDAP-Server-Schwachstelle für Linux und einen Zero-Day in einem beliebten Java-Framework.

Lokale Privilegieneskalation im Linux-Kernel

Ein Heap-Pufferüberlauf wurde im IPsec-ESP-Transformationscode in net/ipv4/esp4.c und net/ipv6/esp6.c gefunden. Laut NVD ermöglicht dieser Fehler einem lokalen Angreifer mit Benutzerrechten, die Kernel-Heap-Objekte zu überschreiben und möglicherweise eine lokale Privilegienerweiterung zu verursachen. Die Schwachstelle trägt die Nummer CVE-2022-27666 mit einem CVSS Base Score von 7.8. Der Exploit für die Sicherheitslücke scheint auf GitHub verfügbar zu sein und behauptet, eine lokale Privilegienerweiterung auf dem neuesten Ubuntu Desktop 21.10 zu erreichen. Der Fix für diese Schwachstelle wurde kürzlich auf Upstream >= 5.10 LTS Kernel angewendet.

Ursache - Der Sicherheitsforscher hinter der Schwachstelle, Xiaochen Zou alias @ETenal7, erklärt: "Die Schwachstelle wurde 2017 mit Commit cac2661c53f3 und Commit 03e2a30f6a27 eingeführt. Die grundlegende Logik dieser Schwachstelle besteht darin, dass der Empfangspuffer einer Benutzernachricht im esp6-Modul ein 8-Seiten-Puffer ist, aber der Absender eine Nachricht senden kann, die größer als 8 Seiten ist, was eindeutig einen Pufferüberlauf verursacht."

Die Ausnutzung dieser Schwachstelle umfasst verschiedene interessante Techniken wie das Heap-Feng-Shui, d. h. die selektive Manipulation des Layouts des Heap-Speicherplatzes, ähnlich einer sorgfältigen Anordnung von Einheiten im Raum im chinesischen System des Feng-Shui. 

Unsachgemäße Authentifizierung in Directory Server 

389 Directory Server ist ein Open Source LDAP Server für Linux. Im 389 Directory Server wurde eine Schwachstelle gefunden, die es ermöglicht, mit abgelaufenen Passwörtern auf die Datenbank zuzugreifen und so eine unzulässige Authentifizierung zu verursachen. Die Schwachstelle trägt die Nummer CVE-2022-0996 und wird mit CVSS 7.5 High bewertet.

Obwohl nicht viele Informationen über diese Sicherheitslücke verfügbar sind, kann das Update mit dem Paketmanager "dnf" installiert werden. Verwenden Sie su -c 'dnf upgrade -advisory FEDORA-2022-2558f14c58' in der Befehlszeile. Weitere Informationen finden Sie in der dnf-Dokumentation.

Laut dem Forscher, der hinter dem Proof-of-Concept steht: "In meinen Tests habe ich nur einen ACI in der Datenbank, der jedem Benutzer, der "authentifiziert" ist, den Zugriff erlaubt. Nach dem Fehler 49 (abgelaufenes Passwort) sollte diese Verbindung als "anonym" betrachtet werden, aber es sieht so aus, als ob sie in Bezug auf die Zugriffskontrolle (ACI) immer noch als "authentifiziert" angesehen wird.

Kritische Zero Day Remote Code Execution in Spring Core

Das Spring-Framework ist ein Anwendungsframework und ein Container für die Umkehrung der Kontrolle auf der Java-Plattform. Die Kernfunktionen des Frameworks können von jeder Java-Anwendung genutzt werden, aber es gibt Erweiterungen für die Erstellung von Webanwendungen auf der Java EE-Plattform. Die Spring WebFlux-Anwendung, die auf JDK 9+ läuft, ist anfällig für Remotecodeausführung (RCE) und trägt die Nummer CVE-2022-22965.

Die CVE wird als kritisch eingestuft und verschiedene vertrauenswürdige Sicherheitsressourcen wie LunaSec und Rapid7 haben das Vorhandensein der Sicherheitslücke bestätigt. Aufgrund des großen Kundenstamms des Frameworks wird die Sicherheitslücke mit der berüchtigten log4shell verglichen und ähnlich benannt, wobei sie diesmal spring4shell heißt. 

Während die Auswirkungen der Sicherheitslücke sicherlich hoch sind, da sie, sobald sie ausgenutzt wird, die Ausführung von beliebigem Code ermöglichen kann, gibt es eine Reihe von Voraussetzungen, damit eine Implementierung ausnutzbar ist. Aus diesem Grund argumentieren einige Sicherheitsforscher, dass die Schwachstelle zwar einen hohen Schweregrad hat, aber nicht so problematisch ist wie die der log4shell. Einige dieser Voraussetzungen sind auch Sicherheitsrisiken, die in den Spring-Dokumenten dokumentiert sind, wie z.B. die Verwendung der Eigenschaft allowfields auf dem Databinder.

Weitere Voraussetzungen sind die Verwendung des Frameworks mit Tomcat in einer WAR-Bereitstellung und aktivierte Spring Beans. Da es sich um einen sich aktiv entwickelnden Vorfall handelt, sind verschiedene Angriffsmöglichkeiten denkbar. Daher wird Kunden, die von der Schwachstelle betroffen sind, empfohlen, eine gründliche Analyse der Implementierung durchzuführen, bevor sie Maßnahmen ergreifen, um das Sicherheitsrisiko zu akzeptieren bzw. zu mindern. Der Blog-Beitrag von LunaSec zu diesem Thema bietet eine ausführliche Erläuterung der Schwachstelle und kann eine hilfreiche Ressource sein, um weitere Informationen und potenzielle Abhilfestrategien zu erhalten. 

Patches sind jetzt für Spring4Shell in den Spring-Versionen 5.3.18 und 5.2.20 verfügbar.


Kommentare

Kommentar abgeben

Ihre E-Mail Adresse wird nicht veröffentlicht.