Debian Jessie migrate from xen

My migration worked fine. Couple of things. I was using the Debian kernel on Xen..Did not boot using legacy grub on kvm.

I switched to the latest 64 bit kernel and it booted.

I installed removed grub-legacy (after extensive experiments) and installed grub2..ran install-grub and

selected grub for boot loader in profile. It runs fine. Only remaining problem is the ajax console won't connect.

Still experimenting with it. If anyone has a solution..please let me know.

fb

5 Replies

Linode Staff

Change your init stuff to start a getty on ttyS0 instead of hvc0.

-Chris

I fixed it..it works btw with the linode kernels w/o adding this but using grub with distro kernel add this to /etc/default/grub

GRUB_TERMINAL=console

GRUBSERIALCOMMAND="serial –unit=0 --speed=115200 --word=8 --parity=no --stop=1"

GRUBCMDLINELINUX_DEFAULT=""

GRUBCMDLINELINUX="text console=tty0 console=ttyS0,115200n8"

Your fix may be easier..I will check that too.

Everything works great..I assume my kvm linode with eventually become non-beta w/o any action on my part?

fb

The following worked for me to migrate a newly installed Debian 8 system to KVM using distro-provided kernel:

  • Keep using linode kernel.

  • Switch to KVM using the button. Make sure "Distro Helper" is enabled, as it takes care of modifying /etc/fstab automatically.

  • apt-get install grub-pc linux-image-amd64

  • Do not select any device like /dev/sda to install GRUB.

  • When asked "Continue without installing GRUB?", say Yes.

  • nano /etc/default/grub

GRUBCMDLINELINUX="console=ttyS0"

  • update-grub

  • Select GRUB2 in Dashboard.

  • reboot

That works too. Simpler. I revised my settings.

I did have a problem with Dovecot not starting after reboot (..time backwards error) because of ntp's failure to get time before Dovecot started.

I changed ntp servers and that resolved that issue. I was using the debian default servers and changed to ntp.org servers.

fb

@sanvila:

The following worked for me to migrate a newly installed Debian 8 system to KVM using distro-provided kernel:

  • Keep using linode kernel.

  • Switch to KVM using the button. Make sure "Distro Helper" is enabled, as it takes care of modifying /etc/fstab automatically.

  • apt-get install grub-pc linux-image-amd64

  • Do not select any device like /dev/sda to install GRUB.

  • When asked "Continue without installing GRUB?", say Yes.

  • nano /etc/default/grub

GRUBCMDLINELINUX="console=ttyS0"

  • update-grub

  • Select GRUB2 in Dashboard.

  • reboot

I just want to add to this, while obvious in hindsight… If you're using a custom kernel, you'll have to recompile it for KVM depending on your compile options. mine had XEN-specific options so it wouldn't boot. Just boot with a linode supplied kernel, remove the old kernel and recompile a new one. I also removed all old grub packages and installed grub2 so I could boot with the grub 2 option instead of the legacy one.

I followed: https://www.linode.com/docs/tools-refer … ith-pvgrub">https://www.linode.com/docs/tools-reference/custom-kernels-distros/run-a-custom-compiled-kernel-with-pvgrub (oh and mkinitrd is called mkinitramfs under debian)

Reply

Please enter an answer
Tips:

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct