Longview: Your system's clock is slow. Please ensure that ntp is installed and running.

So everything runs fine, also longview. But after a week or so I get this message in Longview:

> Your system's clock is slow. Please ensure that ntp is installed and running.

But the ntp is running and servertime is correct.

What is going wrong here? I'm lost.

23 Replies

@IfThenElse:

@arlen:

[TOP TIP] NTP hasn't been deprecated.

:lol:

well, ntp as a protocol hasn't been deprecated, what was deprecated is the ntp client and daemon in favor of chrony. If your distro is sill using the old ntp client, then it is time to upgrade.

I guess I'm up-to-date. Is a freash install and I update/upgrade weekly.

@IfThenElse:

Maybe this is related?

https://forum.linode.com/viewtopic.php?f=7&t=14688

https://forum.linode.com/viewtopic.php?f=7&t=14688#p73220 That does not sound nice. I just came over to Linode from DO expecting Linode to be very good (also price was a decision). But I don't have those gaps you mention there.

Anyway, I have opened a support ticket so I'm in conversation with Linode. See what that brings.

That's not likely to be related at all. Since you're now on chrony, provide the output of the following commands:

* chronyc -n tracking

  • chronyc -n sources -v

  • chronyc -n sourcestats -v

@IfThenElse:

@arlen:

[TOP TIP] NTP hasn't been deprecated.

:lol:

well, ntp as a protocol hasn't been deprecated, what was deprecated is the ntp client and daemon in favor of chrony. If your distro is sill using the old ntp client, then it is time to upgrade.

That's not correct either. A new version was released just last month.

@dwfreed:

That's not likely to be related at all. Since you're now on chrony, provide the output of the following commands:

* chronyc -n tracking

  • chronyc -n sources -v

  • chronyc -n sourcestats -v

I still don't get it. I think NTP and Chrony are BOTH running now. Is that a problem?

$ chronyc -n tracking Reference ID : 78.46.92.35 (78.46.92.35)

Stratum : 3

Ref time (UTC) : Mon May 1 19:45:35 2017

System time : 0.000037242 seconds slow of NTP time

Last offset : -0.000087849 seconds

RMS offset : 0.000041328 seconds

Frequency : 13.667 ppm fast

Residual freq : -0.005 ppm

Skew : 0.032 ppm

Root delay : 0.017154 seconds

Root dispersion : 0.019619 seconds

Update interval : 518.7 seconds

Leap status : Normal

$ chronyc -n sources -v 210 Number of sources = 4

.– Source mode '^' = server, '=' = peer, '#' = local clock.

/ .- Source state '*' = current synced, '+' = combined , '-' = not combined,

| / '?' = unreachable, 'x' = time may be in error, '~' = time too variable.

|| .- xxxx [ yyyy ] +/- zzzz

|| Reachability register (octal) -. | xxxx = adjusted offset,

|| Log2(Polling interval) –. | | yyyy = measured offset,

|| \ | | zzzz = estimated error.

|| | | \

MS Name/IP address Stratum Poll Reach LastRx Last sample

===============================================================================

^* 78.46.92.35 2 9 377 348 -261us[ -349us] +/- 28ms

^+ 46.4.19.10 2 7 377 84 -922us[ -922us] +/- 33ms

^+ 2a01:4f8:c17:63d5::2 2 10 377 591 +1103us[+1021us] +/- 46ms

^+ 46.163.88.246 2 9 377 495 +556us[ +472us] +/- 42ms

$ chronyc -n sourcestats -v

210 Number of sources = 4

.- Number of sample points in measurement set.

/ .- Number of residual runs with same sign.

| / .- Length of measurement set (time).

| | / .- Est. clock freq error (ppm).

| | | / .- Est. error in freq.

| | | | / .- Est. offset.

| | | | | | On the -.

| | | | | | samples. \

| | | | | | |

Name/IP Address NP NR Span Frequency Freq Skew Offset Std Dev

==============================================================================

78.46.92.35 9 5 38m +0.063 0.159 -133us 59us

46.4.19.10 8 4 779 -0.194 0.242 -962us 28us

2a01:4f8:c17:63d5::2 29 12 188m +0.008 0.021 +678us 94us

46.163.88.246 4 4 34m +0.012 0.798 +513us 29us

$ timedatectl status

Local time: Mon 2017-05-01 21:55:02 CEST

Universal time: Mon 2017-05-01 19:55:02 UTC

RTC time: n/a

Time zone: Europe/Amsterdam (CEST, +0200)

NTP enabled: yes

NTP synchronized: yes

RTC in local TZ: no

DST active: yes

Last DST change: DST began at

Sun 2017-03-26 01:59:59 CET

Sun 2017-03-26 03:00:00 CEST

Next DST change: DST ends (the clock jumps one hour backwards) at

Sun 2017-10-29 02:59:59 CEST

Sun 2017-10-29 02:00:00 CET

P.S.

Linode support asked me to do this:

timedatectl set-ntp true

timedatectl status

Everything was on time, but when I check now (hours later) the message warning disappeared (for the moment). Still wondering if I made a setup erro with the VPS or Chrony changed that or the timedatectl set-ntp true. Also Linode stated:

"Now that your Linode's in sync let's see if the Longview service recognizes it. I'll also ask our Admin team to look into the Longview service to see if it's out of sync itself, just in case". Maybe they changed something?

ntp has been deprecated and now replaced by chrony (chronyd), which is better suited for virtualized environments, that require more frequent synchronization.

switch to chrony and see if that makes a difference, otherwise it sounds like a different problem, maybe related to the one that shows "gaps" in the stats.

.. that doesn't sound likely. My Linodes are inside one second off, running ntp. Never had any time issues.

[TOP TIP] NTP hasn't been deprecated.

@IfThenElse:

ntp has been deprecated and now replaced by chrony (chronyd), which is better suited for virtualized environments, that require more frequent synchronization.

switch to chrony and see if that makes a difference, otherwise it sounds like a different problem, maybe related to the one that shows "gaps" in the stats.

Changed to Chrony, same response ;(

GASOLINE: probably support ticket time.

@arlen:

[TOP TIP] NTP hasn't been deprecated.

:lol:

well, ntp as a protocol hasn't been deprecated, what was deprecated is the ntp client and daemon in favor of chrony. If your distro is sill using the old ntp client, then it is time to upgrade.

You really shouldn't have both chrony installed and running and systemd-timesyncd (which is not ntpd, but a systemd-specific implementation of an NTP client) enabled at the same time. They'll fight over who's right and it'll cause problems. That said, your clock is in sync, according to chrony, so the longview message should clear soon. If I recall correctly, you can restart the longview client, and that will make it clear faster.

To disable systemd-timesyncd and just use chrony, run 'timedatectl set-ntp false' as root or with sudo.

@dwfreed:

You really shouldn't have both chrony installed and running and systemd-timesyncd (which is not ntpd, but a systemd-specific implementation of an NTP client) enabled at the same time. They'll fight over who's right and it'll cause problems. That said, your clock is in sync, according to chrony, so the longview message should clear soon. If I recall correctly, you can restart the longview client, and that will make it clear faster.

To disable systemd-timesyncd and just use chrony, run 'timedatectl set-ntp false' as root or with sudo.

I did that than I get f.e.:

$ chronyc -n sources -v 506 Cannot talk to daemon

So switched back and than it works again:

$ chronyc -n sources -v 210 Number of sources = 4

.– Source mode '^' = server, '=' = peer, '#' = local clock.

/ .- Source state '*' = current synced, '+' = combined , '-' = not combined,

| / '?' = unreachable, 'x' = time may be in error, '~' = time too variable.

|| .- xxxx [ yyyy ] +/- zzzz

|| Reachability register (octal) -. | xxxx = adjusted offset,

|| Log2(Polling interval) –. | | yyyy = measured offset,

|| \ | | zzzz = estimated error.

|| | | \

MS Name/IP address Stratum Poll Reach LastRx Last sample

===============================================================================

^? 188.68.39.148 2 6 3 0 +270us[ +270us] +/- 31ms

^? 79.138.40.123 1 6 1 1 +1200us[+1200us] +/- 13ms

^? 2a01:4f8:141:282::5:1 2 6 1 1 -76us[ -76us] +/- 37ms

^? 197.12.0.14 2 6 1 1 +2476us[+2476us] +/- 88ms

Guess I should dive in this mather because I have no knowledge of it yet.

@IfThenElse:

@arlen:

[TOP TIP] NTP hasn't been deprecated.
well, ntp as a protocol hasn't been deprecated, what was deprecated is the ntp client and daemon in favor of chrony. Deprecated by whom? A claim like that needs citation from a valid source. There's absolutely nothing about that on the npt website, for instance.

In any case, even it were true (which I strongly doubt), it only confuses matters to even mention it. If the ntp daemon had problems leading to the OP's issues it would have been useless all these years.

Fair enough, let me clarify.

Once a major distribution strips a piece of software from being the default one, in favour of another one, then I consider the old software to be deprecated, by the distro at least.

Like when OpenOffice was scrapped for LibreOffice, or when ntpd was scrapped for chrony. Take your pick.

Sure, OpenOffice (or ntpd) is still out there, maybe supported by someone or another, but irrelevant in the grand scheme of things.

Happy now, with my explanation? :mrgreen:

You could of course continue to use the old software or even unsuitable software, I see people using ubuntu as a linode server, but those are mostly kids. I personally find ubuntu an unsuitable distro for a proper server, since I prefer CentOS (for linux) or FreeBSD (for *bsd). But each to his own.

Let the flame wars BEGIN! 8)

Anyway, got a response from Linode about the original topic:

> After checking in with our Admins this is a known bug that sometimes occurs when IPv6 configuration on your Linode isn't working properly. ../..

@IfThenElse:

[..]

Once a major distribution strips a piece of software from being the default one, in favour of another one, then I consider the old software to be deprecated, by the distro at least.[..]

Happy now, with my explanation? :mrgreen:

No, not particularly. "Deprecated" isn't a word to use lightly. If a distro or some obscure OS decide to replace their default variant for a particular function with some other variant, that doesn't mean the first one is 'deprecated' in the grand scheme of things. When you call 'ntpd' "deprecated" it implies that there's something seriously wrong with it and it shouldn't be used.

What does deprecated mean? SSL 2.0 is deprecated. SSL 3.0 is deprecated. By whom? Well, by RFCs 6176 and 7568 (both versions have been cracked, thus "deprecated"). The 'gets' system call is deprecated. Why? Because it's insecure. Where is the problem described? In CWE 242. And so on. That's what "deprecated" means. It doesn't have anything to do with whatever a given distro or OS chooses to use, and throwing the word around indiscriminately serves no useful purpose at all, it only muddies the waters.

tomayto-tomahto :roll:

If its not default, its deprecated. Let me know how many distros still use OpenOffice by default…

@T-A:

No, not particularly. "Deprecated" isn't a word to use lightly. If a distro or some obscure OS decide to replace their default variant for a particular function with some other variant, that doesn't mean the first one is 'deprecated' in the grand scheme of things. When you call 'ntpd' "deprecated" it implies that there's something seriously wrong with it and it shouldn't be used.

What does deprecated mean? SSL 2.0 is deprecated. SSL 3.0 is deprecated. By whom? Well, by RFCs 6176 and 7568 (both versions have been cracked, thus "deprecated"). The 'gets' system call is deprecated. Why? Because it's insecure. Where is the problem described? In CWE 242. And so on. That's what "deprecated" means. It doesn't have anything to do with whatever a given distro or OS chooses to use, and throwing the word around indiscriminately serves no useful purpose at all, it only muddies the waters.

Sorry, that's rubbish. The OP reported a technical problem, and you pointed your finger at ntpd, calling it "deprecated". The only reason to connect the problem to a 'deprecated' (which it isn't) ntpd, would be if it was somehow a potential cause. As if it had an error or was unreliable and therefore deprecated. You used the word in the meaning I described (and that's how "deprecated" is used in the industry). Now you're just backpedaling.

Now you are just being childish.

Anyway, I'm not that technical advanced as you both seem to be. But I switched off Chrony. Guess I don't need it for a live server. See what happens.

Problem is back since today:

> Your system's clock is slow. Please ensure that ntp is installed and running.

Guess it's support time again.

Reply

Please enter an answer
Tips:

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct