The requested URL was not found on this server

Hello, i am having a problem when loggin to a site hosted on Linode 1GB using debian, the problem reads as follow "The requested URL /process_login was not found on this server.", but the same site works perfectly on my localhost

6 Replies

Great, this worked perfectly.

How do I close the question?

@buzzly:

If you have .htaccess in tact, and mod_rewrite is installed then you probably need to empower .htaccess with:

 <directory path="" to="" your="" document-root="">AllowOverride all</directory> 

Place this in your virtualhost config. Remember to update the path to match the path of your DocumentRoot.

Not enough information but at a guess, mod_rewrite is not enabled in Apache.

Thank you for the response, But the mod_rewrite module is enabled in apache, what else could it be? or do you have any other question to help troubleshoot?

Next guess, the .htaccess file is missing completely or is missing the required rewrite rules.

Hello, no, it is not missing, it contains the following.

options -indexes

RewriteEngine on

RewriteRule ^(application|system|.svn) index.php/$1 [L]

RewriteCond %{REQUEST_FILENAME} !-f

RewriteCond %{REQUEST_FILENAME} !-d

RewriteCond $1 !^(index.php|public|images|robots.txt|css)

RewriteRule ^(.*)$ index.php/$1 [L]

If you have .htaccess in tact, and mod_rewrite is installed then you probably need to empower .htaccess with:

 <directory path="" to="" your="" document-root="">AllowOverride all</directory> 

Place this in your virtualhost config. Remember to update the path to match the path of your DocumentRoot.

Reply

Please enter an answer
Tips:

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct