SSL Letsencrypt installation issue

Avatar forum:Pav3232 6 months, 1 week ago

Hi Guys ,

I am new to this and trying to do as much as possible on my own to learn the things on the way . I am trying to install SSL Letsencrypt cert for my website however below error occured :````
(Y)es/(N)o: Y
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for example.com
http-01 challenge for www.example.com
Cleaning up challenges
Problem binding to port 80: Could not bind to IPv4 or IPv6.

````

I guess that is something to do with Apache and switching it from port 80 to 443 but not sure how to do it and if that is the right thing to do in the first place. Can you advise please ?

Thank you

4 Replies

Can you provide more information?

> My domain is:

I ran this command:

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version):

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

Hey mnordhoff,

Thanks for your reply :

@mnordhoff:

My domain is: www.workingcapitalaid.com

I ran this command: https://linode.com/docs/security/ssl/in … tificates/">https://linode.com/docs/security/ssl/install-lets-encrypt-to-create-ssl-certificates/ I run it to the point : CHECK CERTIFICATE DOMAINS where just before I got the error which I posted in the original thread

It produced this output: Instead of Congratulations! (like you see on the link above screen shoot) I got the message :

Obtaining a new certificate

Performing the following challenges:

http-01 challenge for workingcapitalaid.com

http-01 challenge for www.workingcapitalaid.com

Cleaning up challenges

Problem binding to port 80: Could not bind to IPv4 or IPv6.

My web server is (include version): Apache httpd 2.4.29 ( I believe it is , how do I check it ? Was installing it under the supervision of Pro Developer but now I have to figure it out myself)

The operating system my web server runs on is (include version): Centos 07

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): I am running Wordpress on my site

It can not bind because you already have something (Apache) running on port 80, or because you're running it as non-root.

Stop apache, run the certificate generation and then start apache again. You can also do this with pre and post hook options with certbot or, alternatively, use an apache-specific letsencrypt plugin.

I have tried to install LetsEncrypt in Ubuntu 16.04 and Apache for days… (Yes, I am a newbie, that is not a crime to be punished: bad, partial instructions are!).

Unfortunately this (https://www.linode.com/docs/security/ss … tificates/">https://www.linode.com/docs/security/ssl/install-lets-encrypt-to-create-ssl-certificates/) does not tell all the story: once you install the certificate, you still have to configure the web server (why it is so hard to find out this simple thing in many instruction pages???)

I found these instructions more helpful: https://www.linode.com/docs/security/ss … tificates/">https://www.linode.com/docs/security/ssl/install-lets-encrypt-to-create-ssl-certificates/

To install the LetsEncrypt client, which automates everything for you, this might be helpful: https://github.com/certbot/certbot/issues/3854. Concerning this post, what worked for me was: sudo apt-get install python-letsencrypt-apache

Reply

Please enter an answer
Tips:

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct