Timezone issues

We started experiencing issues to sync dates with a third party service provider. Currently, the server date is set to UTC but still a problem. We tried to set the hardware clock but we are getting an error.

When we try to communicate with a remote server, the remote server is not receiving the correct timezone so it throws an error. Any thoughts to solve this issue? The server was working from months ago until we noticed yesterday the errors.

Here is the error response from the third party service.

0|app | dnsErrorData

0|app | { status: 400,

0|app | response: { error: [ 'Request sent with date header too >far out of sync. Difference in times is 60457, header value is >1530165197000' ] } }

0|app | dnsData

0|app | { status: 400,

0|app | response: { error: [ 'Request sent with date header too >far out of sync. Difference in times is 60457, header value is >1530165197000' ] } }

Thanks!

1 Reply

The first step to resolving this is making sure that the time on your local server is correct. Using the following command will tell you what the status of the Network Time Protocol(NTP) is on your Linode:

$ ntpq -p

Using these commands will ensure that port 123, the port that NTP uses, is working properly

$ sudo iptables -A OUTPUT -p udp -m udp -m multiport --dports 123 -m state --state NEW -j ACCEPT
$ sudo iptables -A INPUT -m state --state NEW -p udp --dport 123 -j ACCEPT

Here are some really helpful guides on how to configure NTP:

https://blogging.dragon.org.uk/setting-up-ntp-on-ubuntu-14-04/
https://help.ubuntu.com/lts/serverguide/NTP.html.en

Reply

Please enter an answer
Tips:

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct