443 port is not listening

Hi
i have configured ssl conf and enabled ssl mode , but not listening 443 and as a result my site is not working. when i disable ssl mode my site is listening to port 80 and site is working .

4 Replies

Linode Staff

Hey there,

We'll first want to check the status of your firewall and listening service.

You can check if your port is opening by reviewing your iptables:

iptables -L

You can take a similar approach of reviewing your service listening on 443:

netstat -plunt | grep :443

See if your apache process, or something else, is listening on 443. If Apache is not listening on 443, you can check the status and configuration syntax:

/etc/init.d/apache2 status

Ubuntu/Debian

apache2ctl -t

CentOS and Fedora

httpd -t

We hope that helps! Let us know if you find a cause and resolution.

Sincerely,
Tara T
Linode Support Team

OS is ubuntu 16.04. I have executted the commands suggested by you and found the following results. I am not able to find out root cause of the issue. Further Netstat -lpnt not showing 443 .Kindly advice solution

result of Iptables -L

[email protected]:/etc/apache2/sites-available# iptables -L
Chain INPUT (policy ACCEPT)
target prot opt source destination

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)

target prot opt source destination

netstat -plunt | grep :443

showing blank

/etc/init.d/apache2 status

[email protected]:/etc/apache2/sites-available# sudo /etc/init.d/apache2 status
● apache2.service - LSB: Apache2 web server
Loaded: loaded (/etc/init.d/apache2; bad; vendor preset: enabled)
Drop-In: /lib/systemd/system/apache2.service.d
└─apache2-systemd.conf
Active: inactive (dead) since Mon 2019-10-21 07:02:24 UTC; 48s ago
Docs: man:systemd-sysv-generator(8)
Process: 16371 ExecStop=/etc/init.d/apache2 stop (code=exited, status=0/SUCCESS)
Process: 16353 ExecStart=/etc/init.d/apache2 start (code=exited, status=0/SUCCESS)

Oct 21 07:02:24 localhost systemd[1]: Stopped LSB: Apache2 web server.
Oct 21 07:02:24 localhost systemd[1]: Starting LSB: Apache2 web server…
Oct 21 07:02:24 localhost apache2[16353]: * Starting Apache httpd web server apache2
Oct 21 07:02:24 localhost apache2[16353]: Action 'start' failed.
Oct 21 07:02:24 localhost apache2[16353]: The Apache error log may have more information.
Oct 21 07:02:24 localhost apache2[16353]: *
Oct 21 07:02:24 localhost apache2[16371]: * Stopping Apache httpd web server apache2
Oct 21 07:02:24 localhost apache2[16371]: *
Oct 21 07:02:24 localhost systemd[1]: Started LSB: Apache2 web server.


apache2ctl -t

syntax ok

further i have executed the command

openssl s_client -CApath /etc/ssl/certs/ -connect ssdfashion.com:443

and got the below results

[email protected]:/var/log/apache2# openssl s_client -CApath /etc/ssl/certs/ -connect ssdfashion.com:443
connect: Connection refused
connect:errno=111

Hi
The issue is resolved after private key replaced in virtual host

Reply

Please enter an answer
Tips:

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct