Site Can't Be Reached When Using Domain Name But Works With IP Address

Hey all.

I set a Wordpress site up via Linode yesterday. When I type in the domain name: comfortserviceshvac.net, it doesn't work. However, it did work yesterday.

It also works when I type the IP address into the search bar.

I did update the DNS prior to it working yesterday and have not made any changes.

Any ideas on what's going on or what I should do?

4 Replies

whois comfortserviceshvac.net shows the following name servers:

Name Server: NS1.LINODE.COM
Name Server: NS2.LINODE.COM
Name Server: NS3.LINODE.COM
Name Server: NS4.LINODE.COM
Name Server: NS5.LINODE.COM

However, Linode's nameservers are not serving your domain (note the status: REFUSED).

% dig @ns1.linode.com comfortserviceshvac.net

; <<>> DiG 9.16.8 <<>> @ns1.linode.com comfortserviceshvac.net
; (2 servers found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: REFUSED, id: 63132
;; flags: qr rd; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 1
;; WARNING: recursion requested but not available

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 1232
;; QUESTION SECTION:
;comfortserviceshvac.net.       IN      A

;; Query time: 50 msec
;; SERVER: 2400:cb00:2049:1::a29f:1a63#53(2400:cb00:2049:1::a29f:1a63)
;; WHEN: Fri Dec 25 19:53:27 PST 2020
;; MSG SIZE  rcvd: 52

If you set the nameservers with your domain's registrar to Linode's nameservers, then you need to set up DNS records for your domain in Linode's DNS manager. However, you are not required to use Linode's nameservers for your domain in order to host on Linode. If you're setting your DNS records for your domain somewhere else, then you may need to use that somewhere else's nameservers instead of Linode's nameservers. Which brings me to this:

I did update the DNS prior to it working yesterday and have not made any changes.

May I ask what specific updates were made, where they were made, and what these values were before and after the update?

Thanks for the quick response!

I added the 5 linode nameservers. I also added a custom resource record on Google Domains with my linode IP address.

Are you saying that I could just revert back to the regular Google nameservers and the website should just work?

Based on what you wrote, I did add the domain on my Linode (I previously didn't have that so thanks for that tip), but it still isn't working.

Are you saying that I could just revert back to the regular Google nameservers and the website should just work?

Yes. However, keep in mind that DNS changes are not instantaneous; resolvers may cache old responses for a period of time determined by the TTL of the record when it was fetched.

I tested just now, and saw that the domain is resolving now and I get an HTTP response.

% dig comfortserviceshvac.net

; <<>> DiG 9.16.8 <<>> comfortserviceshvac.net
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 4837
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;comfortserviceshvac.net.       IN      A

;; ANSWER SECTION:
comfortserviceshvac.net. 86208  IN      A       66.175.211.42

;; Query time: 1 msec
;; SERVER: 173.230.145.5#53(173.230.145.5)
;; WHEN: Fri Dec 25 20:44:34 PST 2020
;; MSG SIZE  rcvd: 68
% curl -I comfortserviceshvac.net
HTTP/1.1 200 OK
Date: Sat, 26 Dec 2020 04:50:26 GMT
Server: Apache/2.4.38 (Debian)
X-UA-Compatible: IE=edge
Link: <http://66.175.211.42/index.php?rest_route=/>; rel="https://api.w.org/"
Content-Type: text/html; charset=UTF-8

Awesome. Thanks!

Reply

Please enter an answer
Tips:

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct