Pointing a domain name to your server

Avatar forum:christina 9 years, 7 months ago

I have a domain name registered through a different company how do I make it so when u go to that domain name it goes to my server? Is it something with the dns?

11 Replies

You will need to create an A record for that domain to point to the IP address of your server.

The easiest way to go about this is to use Linode's free DNS manager. Log into your domain registrar's control panel, and amend your name server entries to reflect the ones below.

NS1.LINODE.COM

NS2.LINODE.COM

NS3.LINODE.COM

NS4.LINODE.COM

Once you have pointed your domain to the Linode name servers, you will need to log into the Linode Manager (control panel), and click on the 'DNS Manager' tab. Create a new zone for your domain by clicking on the 'Add a new domain zone' link and follow the instructions on the zone builder.

Once you save the zone, you can create an A record entry to have the domain point to the IP address your VPS uses.

I hope this helps.

Well, there's actually no need to add A entries and so on, unless you're doing something fancy. Just add a zone and let the automated tool create the relevant records for you! Linode rulz :D

It may take a few hours for DNS changes to take effect.

is the sub domain the domain I want to be forward to. For example the domain I want to move is "blokmovaz.com"

@christina:

is the sub domain the domain I want to be forward to. For example the domain I want to move is "blokmovaz.com"

An example of a sub-domain is foobar.blokmovaz.com – Where foobar is the sub-domain of blokmovaz.com. Following the instructions above will achieve exactly what you are trying to do :)

As hybinet mentioned, you won't need to manually edit the A record (unless you decide you want it to point somewhere else) -- The zone creation tool will automatically point the domain to the IP address of your Linode VPS.

OKay cool so I just import a zone and then when it asks me for my name server what do I put in?

@christina:

OKay cool so I just import a zone and then when it asks me for my name server what do I put in?

You don't import the zone, follow these steps:

1. Log into your domain registrars control panel (where you registered the domain).

2. You need to edit the name servers of your domain to point to the Linode ones:

NS1.LINODE.COM

NS2.LINODE.COM

NS3.LINODE.COM

NS4.LINODE.COM

3. Save your changes, and log out of your registrar's control panel.

4. Log into https://www.linode.com/members/

5. Click on the "DNS Manager" Tab.

6. Click on the "Add a new domain zone" link (bottom right).

7. Enter your Domain Name.

8. Click continue.

9. Add your email address to the SOA E-Mail field.

10. Click Save.

11. Wait for the DNS to propagate (which can take a little while).

By default, it will have your domain point to the IP address of your Linode VPS.

and where it asked for domain i shoudl type in blokmovaz.com?

thanks for all ur help you guys rock!

okay so I switched everything but whatn I go to blokmovaz.com it takes forever to even connect and then it just gives me an error

"Network Timeout

The server at www.blokmovaz.com is taking too long to respond.

The requested site did not respond to a connection request and the browser has stopped waiting for a reply.

  • Could the server be experiencing high demand or a temporary outage? Try again later.

  • Are you unable to browse other sites? Check the computer's network connection.

  • Is your computer or network protected by a firewall or proxy? Incorrect settings can interfere with Web browsing.

  • Still having trouble? Consult your network administrator or Internet provider for assistance."

here is what I changed

http://christinarule.com/Picture 202.png

http://christinarule.com/Picture 201.png

@christina:

The server at www.blokmovaz.com is taking too long to respond.
That name resolves to a 192.168 address which is not accessible from the Internet. You'll need to set the names to resolve to your public address for the site to work.

-James

hey james… how do i change that?

After changing these configurations, seems to worked, but is not opening my site.
It's opening a folder Index of /
.well-known/

But if o try to open de host via ip or hostname on the browser, it works fine and open my site correctly.

Do I have to change anything else?

Reply

Please enter an answer
Tips:

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct