Setting up mail with Citadel

Hi all,

I just got a new Debian server set up running Apache, ejabberd, and some other stuff. I've got some experience rolling my own Linux server, but one thing that has always thrown me for a loop is setting up email.

I got Citadel installed and working and I have my user account set up, but for some reason it's not working 100%. I can send mail FROM my server, and receive it elsewhere, but I cannot send mail TO my server and have it show up anywhere.

On a (semi?) related note, I also cannot send mail via PHP. (For example, I have a contact form on my web site that's just supposed to relay me an email, and it is not working right now.)

Any ideas on any of these would be most appreciated!

EDIT: Another potentially important piece of information is that I get this every time I start the Citadel server.

Message from [email protected] at Jan 24 23:29:07 ...
 citadel: citserver: Can't bind: Address already in use

Message from [email protected] at Jan 24 23:29:07 ...
 citadel: citserver: Can't bind: Address already in use

Message from [email protected] at Jan 24 23:29:07 ...
 citadel: citserver: Can't bind: Address already in use

Message from [email protected] at Jan 24 23:29:07 ...
 citadel: Citadel had trouble on starting up. We couldn't bind all ports you configured to be provided by citadel server. This means, citadel won't be the service provider for a specific service you configured it to.#012#012If you don't want citadel to provide these services, turn them off in WebCit via Admin->System Preferences->Network.#012#012The failed ports and sockets are: TCP port 0.0.0.0;5222; (XMPP) i#012TCP port 0.0.0.0;25: (SMTP-MTA) a#012TCP port 0.0.0.0:587: (SMTP-MSA) #012#012If you want citadel to provide you with that functionality, check the output of "netstat -lnp" on linux Servers or "netstat -na" on *BSD and stop the programm, that binds these ports. You should eventually remove  their initscripts in /etc/init.d so that you won't get this trouble once more.#012 After that goto Administration -> Shutdown Citadel to make Citadel retry to bind this port.#012#012#012To make both ways actualy take place restart the citserver with "sendcommand down"#012#012The errors returned by the system were:#012citserver: Can't bind: Address already in uset#012; citserver: Can't bind: Address already in useo#012; citserver: Can't bind: Address already in use; #012You can recheck the above if you follow this faq item:#012http://www.citadel.org/doku.php/faq:mastering_your_os:net#netstat

Message from [email protected] at Jan 24 23:29:07 ...
 citadel: Startup Problems

Message from [email protected] at Jan 24 23:29:07 ...
 citadel: Citadel had trouble on starting up. We couldn't bind all ports you configured to be provided by citadel server. This means, citadel won't be the service provider for a specific service you configured it to.#012#012If you don't want citadel to provide these services, turn them off in WebCit via Admin->System Preferences->Network.#012#012The failed ports and sockets are: (null)#012#012If you want citadel to provide you with that functionality, check the output of "netstat -lnp" on linux Servers or "netstat -na" on *BSD and stop the programm, that binds these ports. You should eventually remove  their initscripts in /etc/init.d so that you won't get this trouble once more.#012 After that goto Administration -> Shutdown Citadel to make Citadel retry to bind this port.#012#012#012To make both ways actualy take place restart the citserver with "sendcommand down"#012#012The errors returned by the system were:#012(null)#012You can recheck the above if you follow this faq item:#012http://www.citadel.org/doku.php/faq:mastering_your_os:net#netstat

Message from [email protected] at Jan 24 23:29:07 ...
 citadel: Startup Problems

2 Replies

@Timelord:

Hi all,

I just got a new Debian server set up running Apache, ejabberd, and some other stuff. I've got some experience rolling my own Linux server, but one thing that has always thrown me for a loop is setting up email.

I got Citadel installed and working and I have my user account set up, but for some reason it's not working 100%. I can send mail FROM my server, and receive it elsewhere, but I cannot send mail TO my server and have it show up anywhere.

On a (semi?) related note, I also cannot send mail via PHP. (For example, I have a contact form on my web site that's just supposed to relay me an email, and it is not working right now.)

Any ideas on any of these would be most appreciated!

EDIT: Another potentially important piece of information is that I get this every time I start the Citadel server.

Message from [email protected] at Jan 24 23:29:07 ...
 citadel: citserver: Can't bind: Address already in use

Message from [email protected] at Jan 24 23:29:07 ...
 citadel: citserver: Can't bind: Address already in use

Message from [email protected] at Jan 24 23:29:07 ...
 citadel: citserver: Can't bind: Address already in use

Message from [email protected] at Jan 24 23:29:07 ...
 citadel: Citadel had trouble on starting up. We couldn't bind all ports you configured to be provided by citadel server. This means, citadel won't be the service provider for a specific service you configured it to.#012#012If you don't want citadel to provide these services, turn them off in WebCit via Admin->System Preferences->Network.#012#012The failed ports and sockets are: TCP port 0.0.0.0;5222; (XMPP) i#012TCP port 0.0.0.0;25: (SMTP-MTA) a#012TCP port 0.0.0.0:587: (SMTP-MSA) #012#012If you want citadel to provide you with that functionality, check the output of "netstat -lnp" on linux Servers or "netstat -na" on *BSD and stop the programm, that binds these ports. You should eventually remove  their initscripts in /etc/init.d so that you won't get this trouble once more.#012 After that goto Administration -> Shutdown Citadel to make Citadel retry to bind this port.#012#012#012To make both ways actualy take place restart the citserver with "sendcommand down"#012#012The errors returned by the system were:#012citserver: Can't bind: Address already in uset#012; citserver: Can't bind: Address already in useo#012; citserver: Can't bind: Address already in use; #012You can recheck the above if you follow this faq item:#012http://www.citadel.org/doku.php/faq:mastering_your_os:net#netstat

Message from [email protected] at Jan 24 23:29:07 ...
 citadel: Startup Problems

Message from [email protected] at Jan 24 23:29:07 ...
 citadel: Citadel had trouble on starting up. We couldn't bind all ports you configured to be provided by citadel server. This means, citadel won't be the service provider for a specific service you configured it to.#012#012If you don't want citadel to provide these services, turn them off in WebCit via Admin->System Preferences->Network.#012#012The failed ports and sockets are: (null)#012#012If you want citadel to provide you with that functionality, check the output of "netstat -lnp" on linux Servers or "netstat -na" on *BSD and stop the programm, that binds these ports. You should eventually remove  their initscripts in /etc/init.d so that you won't get this trouble once more.#012 After that goto Administration -> Shutdown Citadel to make Citadel retry to bind this port.#012#012#012To make both ways actualy take place restart the citserver with "sendcommand down"#012#012The errors returned by the system were:#012(null)#012You can recheck the above if you follow this faq item:#012http://www.citadel.org/doku.php/faq:mastering_your_os:net#netstat

Message from [email protected] at Jan 24 23:29:07 ...
 citadel: Startup Problems

Most likely you have another smtpd daemon running on port 25, stop it. lsof -n -i tcp

It appears that incoming email wasn't working due to two things: not giving it enough time (presumably for DNS to start working), and an overly aggressive spam filter. Both of these have been resolved, and mail is coming through now.

Additionally, after restarting the server, I no longer get the Citadel error I posted above.

However there is still one thing that is not working, and that is being able to send mail from PHP scripts. The contact form on my web site still returns an error when I attempt to send a message through it. Once I get that resolved, it looks like I'm all set!

Reply

Please enter an answer
Tips:

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct