I'm getting an error when I try to update my system with yum: "failure: repodata/repomd.xml from base"

Linode Staff

I tried to run yum update today, but I get this error:

Error importing repomd.xml for base: Damaged repomd.xml file

How can I fix this?

1 Reply

It looks like there might have been a temporary issue with either the server or the mirror when yum tried to grab data. You could try to clear yum's cache and repo data, then reimport with yum update

First, try to clean Yum's cache (so that it has a reason to reimport)

$ yum clean all

Then (just to be safe), manually remove the cache. Yum should just recreate this on the next step.

$ rm -rf /var/cache/yum


$ yum update

Let us know if this sorts it out for you.


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct