linode and cloudflare

ive been using cloudflare for 24 hours now and it seems to really slow down my site. ive read all their docs, pared most of the options back, am running no apps, etc. i did notice some talk over there that some hosts dont play well with cloudflare, godaddy being the most mentioned offender.

im curious if anyone is running their linode through cloudflare and what their experience has been. is there some trick to experiencing the sweet joy so many talk about?

20 Replies

I've been using Cloudflare since they were in Beta, and never had much of a problem, though it does seem to speed up my static websites more than my Wordpress sites.

@bryantrv:

I've been using Cloudflare since they were in Beta, and never had much of a problem, though it does seem to speed up my static websites more than my Wordpress sites.

GoDaddy shouldn't be an issue. Did you make sure that you don't have anything blocking or limiting our requests at the host or server level? Some quick things to check:

http://www.cloudflare.com/wiki/I_keep_s … Offline%22">http://www.cloudflare.com/wiki/Ikeepseeing%22MySiteisOffline%22

do we know for certain that the cloudflare ips are whitelisted by linode and are not being throttled?

Linode doesn't have any 'whitelist' for them to be on in the first place…

@JshWright:

Linode doesn't have any 'whitelist' for them to be on in the first place…

Staff from Linode could answer this. I do know that some services throttle if they a lot of connections coming from certain IPs, something that could happen because we act as a reverse proxy, so installing mod_cloudflare to pass along original visitor IPs might help as well.

http://www.cloudflare.com/wiki/Log_Files

@JshWright:

Linode doesn't have any 'whitelist' for them to be on in the first place… i cant imagine anyone running a pro network that wouldnt have some sort of precautions against ddos and the like.

@damoncloudflare:

@JshWright:

Linode doesn't have any 'whitelist' for them to be on in the first place…

Staff from Linode could answer this. I do know that some services throttle if they a lot of connections coming from certain IPs, something that could happen because we act as a reverse proxy, so installing mod_cloudflare to pass along original visitor IPs might help as well.

http://www.cloudflare.com/wiki/Log_Files i spent an entire evening trying to compile that, but it failed relentlessly. no amount of installs and google-foo could solve my problems. it sure would be great if somebody knew where to find a compiled .so

Do you know what the errors were? Our engineers can generally figure out what was causing the compiling issue. I would simply need the error codes you were getting back from your install attempt.

@damoncloudflare:

Do you know what the errors were? Our engineers can generally figure out what was causing the compiling issue. I would simply need the error codes you were getting back from your install attempt. ````
[email protected]:~# apxs2 -iac modcloudflare.c /usr/share/apr-1.0/build/libtool --silent --mode=compile --tag=disable-static i486-linux-gnu-gcc -prefer-pic -DLINUX=2 -DFORTIFYSOURCE=2 -DGNUSOURCE -DLARGEFILE64SOURCE -DREENTRANT -I/usr/include/apr-1.0 -I/usr/include/openssl -I/usr/include/xmltok -pthread -I/usr/include/apache2 -I/usr/include/apr-1.0 -I/usr/include/apr-1.0 -c -o modcloudflare.lo modcloudflare.c && touch mod_cloudflare.slo
/usr/share/apr-1.0/build/libtool: line 970: i486-linux-gnu-gcc: command not found
apxs:Error: Command failed with rc=65536

ubuntu 10.04.2

[email protected]:~# ls /usr/bin/gcc*
/usr/bin/gcc /usr/bin/gcc-4.1 /usr/bin/gccbug-4.1

````

Checking it out with our mod_cloudflare wiz.

@damoncloudflare:

Checking it out with our mod_cloudflare wiz.

Here's what he suggested trying:

/usr/share/apr-1.0/build/libtool –silent --mode=compile --tag=disable-static gcc -prefer-pic -DLINUX=2 -DFORTIFYSOURCE=2 -DGNUSOURCE -DLARGEFILE64SOURCE -DREENTRANT -I/usr/include/apr-1.0 -I/usr/include/openssl -I/usr/include/xmltok -pthread -I/usr/include/apache2 -I/usr/include/apr-1.0 -I/usr/include/apr-1.0 -c -o modcloudflare.lo mod_cloudflare.c

that compiles but the resulting module kills apache.

can somebody with more skill please compile mod_cloudflare for me? i have spent so many hours on this :(

http://www.cloudflare.com/wiki/Log_Files

given up on cloudflare.

its a great idea, but its too much of a pain in the ass to get running well.

@carol:

i cant imagine anyone running a pro network that wouldnt have some sort of precautions against ddos and the like.

By default, there is a 50 Mb/sec rate limit on outgoing traffic from each Linode. As far as I can tell, that is all the filtering that occurs upstream of an individual Linode, unless there actually is a DDoS.

@damoncloudflare:

Staff from Linode could answer this. I do know that some services throttle if they a lot of connections coming from certain IPs, something that could happen because we act as a reverse proxy, so installing mod_cloudflare to pass along original visitor IPs might help as well.

I've not noticed this happening, even with obviously bad traffic. Last week, I handled ~150 SIP registration attempts per second from one IP address. Lasted about 18 hours until I got around to iptablesing it. Then again, it was only about 1.5 Mb/sec, which is small potatoes in the grand scheme of things.

How many hits/second are we talking about here?

I was testing CloudFlare with a web site on my Ubuntu 10.04 server today and encountered the same problem carol reported.

I installed apxs2:

> $ sudo apt-get install apache2-prefork-dev

I then attempted to build the CloudFlare mod but received an error.
> $ sudo apxs2 -iac mod_cloudflare.c

/usr/share/apr-1.0/build/libtool –silent --mode=compile --tag=disable-static i686-linux-gnu-gcc -prefer-pic -DLINUX=2 -DFORTIFYSOURCE=2 -DGNUSOURCE -DLARGEFILE64SOURCE -DREENTRANT -I/usr/include/apr-1.0 -I/usr/include/openssl -I/usr/include/xmltok -pthread -I/usr/include/apache2 -I/usr/include/apr-1.0 -I/usr/include/apr-1.0 -c -o modcloudflare.lo modcloudflare.c && touch modcloudflare.slo

/usr/share/apr-1.0/build/libtool: line 978: i686-linux-gnu-gcc: command not found

apxs:Error: Command failed with rc=65536

.

I wrongly assumed libtool was installed and working correctly. It wasn't. So I did the following.

Install libtool (even though it's already on the server):

> $ sudo apt-get install libtool

Build and install extenstion module:

> $ apxs2 -iac mod_cloudflare.c

Restart apache2:

> $ sudo /etc/init.d/apache2 restart

Check the access log to confirm that the mod is working.

Hope this helps.

CloudFlare Beta user also since inception. Every domain on cF and will never look back. As an authoritative DNS you cannot beat it and BL IP denial is the icing. I run about 20 domains, several on their Pro service.

@Carole same config, (2) Linodes 512, ubu 10, apache2, php, mysql (nginx)

I don't use modcloudflare or realip for those reasons you have trouble compiling but sites are faster than other options I've experimented with… I only run small tight communities however, WordPress and serve apps to soc through sub-domains. With the cF plugin and Visitor Maps I don't tail my logs via ssh, but see exactly who's online via the cms.

@SpadMan:

I was testing CloudFlare with a web site on my Ubuntu 10.04 server today and encountered the same problem carol reported.

Spadman: You're the first person outside CloudFlare and on all the forums (globally) I've scoured that actually said something "different", and "did" it without pointing back to countless dead ends. Very cool. I might have to revisit the mod.

Kudos to you

Stu

@SpadMan:

I was testing CloudFlare with a web site on my Ubuntu 10.04 server today and encountered the same problem carol reported.

I installed apxs2:

> $ sudo apt-get install apache2-prefork-dev

I then attempted to build the CloudFlare mod but received an error.
> $ sudo apxs2 -iac mod_cloudflare.c

/usr/share/apr-1.0/build/libtool –silent --mode=compile --tag=disable-static i686-linux-gnu-gcc -prefer-pic -DLINUX=2 -DFORTIFYSOURCE=2 -DGNUSOURCE -DLARGEFILE64SOURCE -DREENTRANT -I/usr/include/apr-1.0 -I/usr/include/openssl -I/usr/include/xmltok -pthread -I/usr/include/apache2 -I/usr/include/apr-1.0 -I/usr/include/apr-1.0 -c -o modcloudflare.lo modcloudflare.c && touch modcloudflare.slo

/usr/share/apr-1.0/build/libtool: line 978: i686-linux-gnu-gcc: command not found

apxs:Error: Command failed with rc=65536

.

I wrongly assumed libtool was installed and working correctly. It wasn't. So I did the following.

Install libtool (even though it's already on the server):

> $ sudo apt-get install libtool

Build and install extenstion module:

> $ apxs2 -iac mod_cloudflare.c

Restart apache2:

> $ sudo /etc/init.d/apache2 restart

Check the access log to confirm that the mod is working.

Hope this helps. thx for the info.

i will give this a try :)

Did you get this working carol?

I don't think your chances are great to get a response to a thread from 2011….

Reply

Please enter an answer
Tips:

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct