Getting working

I recently moved to Linode from my previous host. I'm still getting my site up and running, but I want to get my email working sooner. I snagged a custom domain email when Microsoft were giving them away last year and set things up on my then-host, and all was well. Before shuttering the old host account, I made record of two TXT and one MX settings pertaining to the Outlook connection. I copied said settings into my Linode DNS late 4/18, and have received no email on the Outlook account since.

The domain is

Investigation on the web has yielded a confusing mess, ranging from needing to migrate to Office 365 to self-hosting mail to not making any MX changes. Gah. I like Outlook and would like to keep that setup if possible. I've also searched the Linode library and found details pertaining to Google Apps, as well as setting up email server, neither of which I'm sure I need.


Domain is registered at Gandi

Email account at

1GB Linode

Linode is set up with LAMP stack, some tools, keyed SSH. Nothing done by me related to email other than DNS settings.

EDIT: it seems I can send email from the account in question, and receive at another address fine. This account just doesn't receive email for some reason.

12 Replies

What's your domain name?


What's your domain name?
See edited OP.

You have no MX records defined.


You have no MX records defined.
The MX setting is there:

Cached values from a lookup I did 2 hours ago:

% nslookup -type=mx

Non-authoritative answer:
*** Can't find No answer

Authoritative answers can be found from:
        origin =
        mail addr = 
        serial = 2015042066
        refresh = 14400
        retry = 14400  
        expire = 1209600
        minimum = 86400

I note that asking directly gives me a single MX and a higher SOA. So that makes me thing you made a change recently.

If you have recently made the change then you need to wait for it to propagate across the net, perhaps up to 24 hours.

You need to set █████████████ then be sure to add ██████ to your ██████████████ file.

Geesh, why do you ask for help then obfuscate any useful info.

Your MX record is wrong. You have your MX pointing to and it needs to be pointing to


Your MX record is wrong. You have your MX pointing to and it needs to be pointing to

% nslookup -type=mx 
Address:  mail exchanger = 10


He also has a MAIL.GRANTPALIN.COM A record.

So is he trying to get OUTLOOK.COM to host his email, or is he moving it to his Linode setup? no longer allows custom domains, and only grandfathers the existing users for domains that were setup before yet another provider says they will host your domain email for free and then screws you over.

That was all addressed in the first entry (he had this domain with and has migrated to linode but wants to keep mail at Without further analysis (eg error reports from sending machines) I think the issue was a lack of MX record (as per my test 2 hours ago), so it should just be a case of waiting for propagation.

If the problem still exists in 24 hours time then more data may be needed! A full error report, for example…

About 2 hours ago I went into the DNS settings and re-submitted the TXT and MX settings - just pasted in the values I had recorded in a text file. A short while after that, I opened the email account to find numerous messages waiting for me. Not sure what happened, but supposing that either the initial settings took close to two days to catch up, or the more recent submission kicked something loose. In any case the account is sending and receiving again.

FWIW the A records were pre-populated when I created the Linode, I just left them alone.

Thanks for the help.

Since I'd never looked up that domain before, the values I pulled in were "live" values.

So either you didn't save the values properly first time or the Linode backend code didn't build the domain properly.

Either way I now see the MX and TXT records.

You guess is as good as mine. I can't tell whether it was my re-submit that made a difference, but the email started flowing a while after that, so I may have had something incorrect the first time. Just as well that I tried it before we spent more time chasing down the issue.

Thanks again.


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct