IPv6 on Linode with Debian Jessie - Can't Ping6 Google

I've been going around in circles with IPv6. Reading a few of the forum posts on IP6 it looks like I have temporary dynamic IP6 addressing happening on eth0.

This wasn't showing up until I rebooted, but ping6 didn't work prior to the reboot either.

server:/home/kangaby.com# ip -6 addr
1: lo: <loopback,up,lower_up>mtu 65536
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <broadcast,multicast,up,lower_up>mtu 1500 qlen 1000
    inet6 2600:3c00::f03c:91ff:fe96:be0e/64 scope global mngtmpaddr dynamic
       valid_lft 2591998sec preferred_lft 604798sec
    inet6 fe80::f03c:91ff:fe96:be0e/64 scope link
       valid_lft forever preferred_lft forever
3: tun0: <pointopoint,multicast,noarp,up,lower_up>mtu 1500 qlen 100
    inet6 2600:3c00:e001:2901::1/64 scope global
       valid_lft forever preferred_lft forever

server:/home/kangaby.com# sysctl -p
net.ipv4.ip_forward = 1

server:/home/kangaby.com# sysctl -a | grep use_tempaddr
net.ipv6.conf.all.use_tempaddr = 0
net.ipv6.conf.default.use_tempaddr = 0
net.ipv6.conf.eth0.use_tempaddr = 0
net.ipv6.conf.lo.use_tempaddr = 0
net.ipv6.conf.tun0.use_tempaddr = 0

server:/home/kangaby.com# ping6 ipv6.google.com
PING ipv6.google.com(oj-in-x71.1e100.net) 56 data bytes
--- ipv6.google.com ping statistics ---
22 packets transmitted, 0 received, 100% packet loss, time 20999ms</pointopoint,multicast,noarp,up,lower_up></broadcast,multicast,up,lower_up></loopback,up,lower_up> 

You probably need more information than I've provided, so just ask for the stuff I've missed.

There is either something simple I've missed or Debian Jessie is doing it differently or with systemd, which I don't understand at all.

I have no IP6Tables stuff:

server:/home/kangaby.com# ip6tables-save

Shutting down openvpn tun0: doesn't make any difference to ping6.

server:/home/kangaby.com# /etc/init.d/openvpn stop
[ ok ] Stopping openvpn (via systemctl): openvpn.service.
server:/home/kangaby.com# ping6 ipv6.google.com
PING ipv6.google.com(ob-in-x71.1e100.net) 56 data bytes
--- ipv6.google.com ping statistics ---
4 packets transmitted, 0 received, 100% packet loss, time 3022ms

Suggestions welcome.

3 Replies

Well this sucks. I've just checked my /etc/resolv.conf which turns out is from a previous (or 2) host change, and the IP4 name servers were not what the current Linode dashboard reports, and there were no IP6 name servers listed at all.

Adding the following from the dashboard

nameserver 2600:3c00::2
nameserver 2600:3c00::3


server:/etc# ping6 ipv6.google.com
PING ipv6.google.com(of-in-x65.1e100.net) 56 data bytes
64 bytes from of-in-x65.1e100.net: icmp_seq=1 ttl=54 time=7.53 ms
64 bytes from of-in-x65.1e100.net: icmp_seq=2 ttl=54 time=7.99 ms
64 bytes from of-in-x65.1e100.net: icmp_seq=3 ttl=54 time=7.48 ms
--- ipv6.google.com ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2002ms
rtt min/avg/max/mdev = 7.480/7.668/7.991/0.229 ms


Why don't you use DHCP? It would take care of populating /etc/resolv.conf appropriately.


Why don't you use DHCP? It would take care of populating /etc/resolv.conf appropriately.

Well, I'm running multiple IPv4 addresses, which requires a static configuration, and even though the IP4 addresses were out of date, they were still working.

My IPv6 address is configured by the SLACC magic. I'm not doing any static configuration for the primary IP6 address, only the routed /56, and then only 1 address.

However, based on the info in sysctl.conf, if I enable IP6 forwarding, it will disable IP6 auto configuration, so I'm probably going to have to do that as static as well.

I thought SLACC and DHCP for IP6 were kind of the same, but probably not. I'm only dabbling in the IP6 world, so there is probably a lot that's new and different. IP4 is a walk in the park compared to IP6.


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct