connecting via ssh - permission denied

I am logging into my linode via ssh and I keep getting permission denied. How do I determine why?

5 Replies

That was the only error I was recieving. Evidently having a ! in the password broke it. But now the root password doesn't work for sftp.. so frustrating.

Recent releases of ssh, by default, do not allow the user root to log in using a password.

(Try "man sshd_config" and read about PermitRootLogin option).

That's not a bad default, however. What you should do is to start using ssh public keys.

What message are you getting back? Typically, the error message tells you why. Usually, wrong password or pubkey.

What user are you trying to connect as?

It is good to keep direct root logins disabled, create a user and add it as sudo

Hi there,

I am encountering this problem.

I created a new linode. I set up my root password. I tried to SSH into my server, but my password/access is denied.

how do you guys do it now?

thanks,

techfang

Reply

Please enter an answer
Tips:

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct