kernel 2.6.5 + bind error

bind proceeds to eat all the cpu.

6 Replies

looks like the first error is here:

"page allocation failure" usually means you're out of RAM+swap.

Check "cat /proc/swaps" to see if that's the case.


Switched to the lastest 2.4 kernel you offer and I haven't had the problem since.

Now that I've switched to kernel 2.6 to get filesystem ACLs, I've been noticing that someone of my bind9 processes have started eating all of my CPU after awhile. Since the links in the original post are no longer active, I can only assume that I'm experiencing the same problem.

Anybody know how I can fix this w/o switching back to kernel 2.4? I really do need filesystem ACLs.

Have you disabled thread local storage? Bind is usually the first thing to cause problems on a Linode that is running with TLS enabled.

mv /lib/tls /lib/tls-disabled

UML does not support NPTL/TLS under 2.4 or 2.6. The difference in the way the TLS problem manifests itself (or not) with 2.4 and 2.6 kernels is because NPTL enabled /lib/ checks 'uname' in 2.4 kernels. If extraversion begins with "-nptl" then the 2.4 kernel has NPTL (and TLS) support. If extraversion doesn't have that string, assumes that the kernel doesn't have NPTL (or TLS) support (the Linode 2.4 case). If the kernel is >=2.6, then just assumes that NPTL (and TLS) support is present, so things start to go haywire under UML, where this assumption is invalid.

Yes, I've disabled TLS. bind is still behaving strangely.

Here's a top display of my named when it goes crazy:

PID  USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND           
8121 bind      25   0 11192 1252 4160 R 98.9  2.1  47:27.35 named


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct