Changed my root password, now sudo say incorrect password

I changed my root password, by shutting down my linode and changing the password in the rescue section.

However after I boot my linode, and login via ssh, when I try to run command that requires sudo. It says incorrect sudo password for user "mayur"

The password I have changed to works in the lish console.

3 Replies

What user are you logged into when you're trying to run these commands that require sudo? You had changed your root user password, so the mayur user's password will remain the same as it was. You can change your mayur user's password with root with a 'passwd mayur' command if you forgot what it was.

Thanks this worked.

Is it worth me changing the key-gen now I have done all of this?

I'm glad it worked!

If you only wanted to change your password for that user, then no, but if you wanted to make new keys anyway then go for it. Changing the password shouldn't leave your key-pair unable to work.


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct