Post_Max_Size PHP 7.0

Hi,

Recently upgraded Ubuntu and along with it PHP from 5.6 to 7.0. My Wordpress file upload settings were wiped out in the process.

I changed php.ini to adjust the Max File Size from 2MB to 64MB but when I checked in wordpress, the max was capped at 8MB. I believe that there is another field called PostMaxSize that is overruling the 64MB, but it isn't showing in this PHP.INI file. I know that there are a few versions of the PHP.INI but figured I was in the right one since it does allow me to change as far as 8MB.

Any idea where the PostMaxSize might be hiding?

;;;;;;;;;;;;;;;;
; File Uploads ;
;;;;;;;;;;;;;;;;

; Whether to allow HTTP file uploads.
; http://php.net/file-uploads
file_uploads = On

; Temporary directory for HTTP uploaded files (will use system default if not
; specified).
; http://php.net/upload-tmp-dir
;upload_tmp_dir =

; Maximum allowed size for uploaded files.
; http://php.net/upload-max-filesize
upload_max_filesize = 64M

; Maximum number of files that can be uploaded via a single request
max_file_uploads = 20

3 Replies

According to: http://php.net/manual/en/ini.core.php

postmaxsize has a default of 8M.

Add this parameter to your php.ini and set it to be the same/bigger than your uploadmaxfilesize.

Remember that in most cases, a change in php.ini won't take effect unless you restart Apache.

phpinfo() should tell you which php.ini is being used

settings in php.ini can be overridden by runtime settings and .htaccess

Reply

Please enter an answer
Tips:

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct