Hugepages - why is it missing?

Avatar forum:sed 7 months, 1 week ago

https://help.ubuntu.com/community/KVM%2 … 0Hugepages">https://help.ubuntu.com/community/KVM%20-%20Using%20Hugepages

sudo sysctl -w vm.nr_hugepages=2048

sysctl: cannot stat /proc/sys/vm/nr_hugepages: No such file or directory

grep HUGETLB /boot/config-4.4.0-36-generic

CONFIGARCHWANTGENERALHUGETLB=y

CONFIGCGROUPHUGETLB=y

CONFIG_HUGETLBFS=y

CONFIGHUGETLBPAGE=y

Kernel supports hugepages.

Not enabled in KVM? Why?

2 Replies

Can you verify what kernel you're booted to?

$ uname -r

By default, Linodes boot to Linode-supplied kernels. I don't know if hugepages are enabled in Linode's kernel (its configuration is in /proc/config.gz if you wish to check). If you wish to boot to a kernel supplied by your distribution, you'll want to make some changes to your Linode's configuration profile as documented at https://linode.com/docs/tools-reference … -with-kvm/">https://linode.com/docs/tools-reference/custom-kernels-distros/run-a-distribution-supplied-kernel-with-kvm/

What's your use case for hugepages on the guest, out of curiousity?

Reply

Please enter an answer
Tips:

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct