disappearing boot console

Ok, so I got impatient for an FC3 image so I used yum to update from FC2 to FC3. For the most part, it went fine.

One odd thing I noticed was that when watching the boot with lish I see:

> Warning: unable to open an initial console.

And I don't see most of the rest of the boot process. Eventually toward the end the console does return, and I get the login prompt.

Does anyone know why the console "disappears" during the middle of the boot? Is this a mismatch between the kernel and the FC3 udev?


3 Replies

To answer my own question:

I've discovered this is a udev related issue. During the FC2 -> FC3 upgrade, the dev rpm, which contains the /dev/console node, is removed. This is normal, since the new udev system will create /dev/console when it starts. But, it doesn't start soon enough at boot.

The solution was to create a /dev/console node in the main filesystem image so that it exists before udev creates it's own version.


Where does this need to be done?

I tried adding

mknod /dev/console c 0 0

to rc.sysinit , but no results

Did you add the mknod before /sbin/start_udev is run in rc.sysinit?

That may be failing because the root device is probably in read only mode at this point in the boot.

If that's the case, you could try remounting the root partition as read/write right before the mknod, but I'm not sure how safe it would be to remount rw that early.

Side note: The /dev/console device node only needs to be added once. Once it's part of the main filesystem image, you don't need to add it each time, you can remove the mknod and any other changes from rc.sysinit.

The way I solved this problem is that I used some of my spare disk space to create a tiny Debian profile. Booted into that, with my Fedora root disk image attached to /dev/ubdc. Then just mounted /dev/ubdc on /mnt and did the mknod in /mnt/dev


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct