Can't see Linode

I previously posted under 'crash on boot' but have since discovered the linode shell, and found my system OK! but…

I can hit my webserver, or ping my system. I had CPanel running and they advised "There is no A record for plato :) Your admin will know how to do basic DNS tasks :)" but…

I've changed the zone record as below, and still no luck

I'm not stong on this any help would be appreciated.

/var/named/ reads as below

; cPanel

; Zone file for

$TTL 14400

@ IN SOA (

2005061001 ; serial, todays date+todays

14400 ; refresh, seconds

7200 ; retry, seconds

3600000 ; expire, seconds

86400 ) ; minimum, seconds IN NS IN NS IN A IN A

plato. IN A IN A IN MX 0



ftp IN A

14 Replies

DNS config for the zone looks fine by me.

$ dig AXFR

; <<>> DiG 9.2.5 <<>> AXFR
; (1 server found)
;; global options:  printcmd      14400   IN      SOA 2005061001 14400 7200 3600000 86400      14400   IN      MX      0      14400   IN      NS      14400   IN      NS      14400   IN      A  14400   IN      A 14400 IN   A 14400   IN      CNAME 14400  IN      A  14400   IN      CNAME
plato.                  14400   IN      A      14400   IN      SOA 2005061001 14400 7200 3600000 86400
;; Query time: 734 msec
;; WHEN: Wed Sep  7 10:13:34 2005
;; XFR size: 12 records

I see some minor wierdness. You have "plato" in the example as a complete top-level hostname, AND as a fully qualified host. See:

plato.                  14400   IN      A 14400  IN      A

This shouldn't break anything, since you have the correct one in there, though you'll probably see log entries for "out of zone data ignored" or some such.

Some lookups will fail because ns1 and ns2 aren't resolving properly. Their glue-records exist on the TLD servers, but not in your zone. You need to add these:  172800  IN      A  172800  IN      A

I'm not sure if this is breaking anything, but the fact that your own zone isn't serving up the IPs for the nameserver hostnames is rather broken.

I'd use shorter TTLs though. 172800 (2 days) and 86400 (1 day), though "standard" are a long time to wait when you have things you need to fix like this. 14400 (4 hours) like your other hostnames isn't bad.

Thanks I added those lines, but there is another problem.

Each time I reboot the linode it reverts to the default host name.

Can I stop it doing this?


Each time I reboot the linode it reverts to the default host name.

Can I stop it doing this?
Have you put your hostname into the /etc/hostname file yet?

I tried this but it still reverted

Does the file /etc/conf.d/hostname exist?

Neither /etc/conf.d/hostname or /etc/conf.d exist

I'm running CentOS 3.5 with CPanel installed.



The file reads:



Sorry for my ignorance here but do append, or replace, the current HOSTNAME value?

You'll want to set HOSTNAME to whatever your host and domain name are. Like so:

However, by default, each Linode acquires its primary (eth0) IP address via DHCP, and that might be overriding your hostname. You'll need to move off using DHCP and use a static configuration. Fairly easiy to do…

Edit /etc/sysconfig/network-scripts/ifcfg-eth0 to have values like so:


You'll also need a GATEWAY line in /etc/sysconfig/network:


That's assuming your IP is

Either reboot, or log into your console via Lish and restart networking (/etc/init.d/network restart) to get those changes.



You'll also need a GATEWAY line in /etc/sysconfig/network

Actually, comparing my RH init scripts to my CentOS box, the CentOS box has the GATEWAY entry in the ifcfg-eth0 file. Either might work, but if not, move that GATEWAY line into the ifcfg-eth0 file.


Many thanks, but I've run into several issues so decided to reinstall.

Once again many thanks for your input.

That was nice and helpful.


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct