Block storage attached but does not appear in file system

I'm having the same problem as described here.
The answer given there, which I understand as basically to follow the instructions for creating a file system on the volume, does not work and seems not to apply.
Specifically, the volume I created some 12 hours ago shows as attached to my linode in Linode Manager. I'm logged in as root to my linode using Lish. I started off trying to make a file system on volume as per the instructions given me:

[email protected]:~# mkfs.ext4 /dev/disk/by-id/scsi-0LinodeVolumemyvolume
mke2fs 1.44.1 (24-Mar-2018)
The file /dev/disk/by-id/scsi-0LinodeVolumemyvolume does not exist and no s.

Aha. A mystery. I've run the following terminal commands and get the following results:

[email protected]:~# ls -lah /dev/disk/by-id
total 0
drwxr-xr-x 2 root root 80 Jun 7 16:56 .
drwxr-xr-x 5 root root 100 Jun 7 16:56 ..
lrwxrwxrwx 1 root root 9 Jun 7 16:56 scsi-0QEMUQEMUHARDDISKdrive-scsi-disa lrwxrwxrwx 1 root root 9 Jun 7 16:56 scsi-0QEMUQEMUHARDDISKdrive-scsi-disb

[email protected]:~# df -h
Filesystem Size Used Avail Use% Mounted on
udev 968M 0 968M 0% /dev
tmpfs 200M 4.9M 195M 3% /run
/dev/sda 49G 5.6G 41G 12% /
tmpfs 997M 0 997M 0% /dev/shm
tmpfs 5.0M 0 5.0M 0% /run/lock
tmpfs 997M 0 997M 0% /sys/fs/cgroup
tmpfs 200M 0 200M 0% /run/user/0

[email protected]:~# fdisk -l
Disk /dev/sda: 49.8 GiB, 53418655744 bytes, 104333312 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

Disk /dev/sdb: 256 MiB, 268435456 bytes, 524288 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

My conclusion: the volume is truly lost. How can I get it back?

Edit: I'm running Ubuntu 18.04 LTS

2 Replies

Hey there,

That certainly is an odd situation. If you power the Linode down and detach the volume, then power the Linode on and reattach it, are you able to see it then? Do you have a Support Ticket open regarding this?

Thank you in advance!

I figured first I'd see if anyone could tell me what stupid thing I've done, but I just now opened a ticket.

Reply

Please enter an answer
Tips:

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct