Community

Accessing google from linode gives different HTTP return code

Avatar tonyjacobk 1 week, 2 days ago

When I use curl to access www.google.com from linode it gives 302 with location at [https://ipv6.google.com/sorry/index?continue=https://www.google.com/&q=EhAmADwDAAAAAPA8k .

But if I access it from my PC , Android phone or IOS phone it gives 200 OK not 302.

Any idea why behavior is different in linode ?

1 Reply

The redirect happens because people like to sign up for Linodes and abuse Google, so Google has blocked a lot of Linode's IPv4 and IPv6 ranges. When blocked, you get redirected to that sorry page (give curl the -L flag to follow redirects) instead.

(Google doesn't submit abuse reports, so there really isn't anything Linode can do about this.)

Reply

Please enter an answer
Tip:

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct