How do I connect to mariadb from my local desktop?

New to Linode, have a linode running debian 9 and I installed mariadb.

I followed to directions from here: https://www.linode.com/docs/databases/mariadb/mariadb-setup-debian/

All worked fine, able to create a db, add a user, grant permissions and login but I want to remote access the database from my windows desktop using Mysql Workbench.

I followed these directions and it failed: https://www.linode.com/docs/databases/mariadb/mariadb-setup-debian/#remote-user-connections

The connection was refused. I'm connecting to the IP address provided on port 3306 using the user I created.

Any help or input about accessing the database on my new linode would be welcome.

3 Replies

Check your firewall settings. You might need to unblock that port.

Ah, right, just did that and is now working.
Thanks

Excellent! Good to hear! Glad to help!

Reply

Please enter an answer
Tips:

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct