My cPanel/WHM on CloudLinux no longer has networking after automated upgrade and reboot

Linode Staff

I have run C-Panel and CloudLinux in this server for several years with no issues at all. Usually when C-Panel upgrades automatically it changes the kernel version and on the top right corner shows the alert that the server needs to be rebooted to get the new version loaded. That is what I did as I always do. I went to the Linode and rebooted. At first I thought the Linode was not rebooted but then I found it did reboot but the network was the one causing this server to be isolated with no connectivity form the outside. It is reachable from the LISH console though. The ping from the server to the outside was working at that time.

Recently I shut down the server and went to settings in Linode and disabled network auto-configuration to see if reenabling it caused any effect, but it didn't. Then I tried to ping from inside the server and it appears the networking is now not working to outbound neither.

12 Replies

What appears to work is to look up your IPv4 default gateway (Usually your IP address with the last octet set to .1) from your "Remote Access" tab of the Linode Manager and edit your /etc/sysconfig/network file to the include the following: (replace $GATEWAY$ with your actual default gateway)


You may need to reboot.

Thanks to a special customer who worked through this issue with us and dsmith who ran with the ball.

If you find that you're running into trouble following the steps above, I found an article from the cPanel site touching on the same topic with a slightly different version of the solution:

I haven't yet tested this myself, but have gotten some positive feedback from others who have tried it.


I had the pleasure of working with someone experiencing this issue, and following the steps outlined in the article I linked, we found a minor adjustment to make. For the sake of the example I'll provide below, let's say your IP address is

  1. From the summary page for your Linode in the Cloud Manager, disable the Network Helper

  2. Edit the following configuration as follows:

nano /etc/sysconfig/network-scripts/ifcfg-eth0



For GATEWAY= use the public IPv4 address of your Linode, changing the last octet to 1
You may see a line in the config as GATEWAY0=; you can replace this line or comment it out by preceding the line with #

  1. Reboot your Linode

If this was the only issue impacting your networking, you should be good to go from here!

I'd like to provide a small update to hphillips's procedure described above.

You will use the "Network" tab on your Linode's summary page in Cloud Manager, which will display the gateway information in the same row as your Linode's IP address. The "Remote Access" tab mentioned by hphillips was used in a previous version of the Linode Manager for providing this information.

The /etc/sysconfig/network file may simply contain a single line reading:

# Created by anaconda

You will want to put hphillips's suggested comments after this line, save the changes, and potentially need to reboot your Linode.

I am updating this issue to make sure that you had the most relevant information for resolving this issue quickly and effectively. Please let us know if you run into any other issues by following up to this question with your own response.

The easiest way to apply this fix is with these two commands:

echo "NETWORKING=yes" >> /etc/sysconfig/network
echo "GATEWAY=<gateway.ip>" >> /etc/sysconfig/network

You will need to replace <gateway.ip> with the actual gateway IP address from your Linode's "Network" tab as I had described earlier. However, you should simply be able to reboot your Linode after applying these changes.

is the srv login and password for the Lesh, are the same i use to login to my Linode account?

@bizzindexcom The username and password for Lish is the same one you created for the server itself. You can log in with root if you don't remember the username and password of any limited user that was created. You can reset the root password following the instructions in the link below.

Hope this helps!

@rdaniels - thanks for the help. Much appreciated.

Hopefully you can help me on this. Since i updated the Cpanel software under my account i cant access this account and my website is not responding. I seeked help from Cpanel support but they are experiencing no server response- as follow:

[Christine N (01:13 PM) ] ~ ping
PING ( 56 data bytes
Request timeout for icmp_seq 0
Request timeout for icmp_seq 1
Request timeout for icmp_seq 2
Request timeout for icmp_seq 3

So please help :)

@bizzindexcom You're welcome! Once you're able to log into your server, the troubleshooting steps in the answers to this question from my teammates should help. Is there a particular step you were having trouble with?

@rdaniel - regarding the srv login, i am not sure what it is. I tried 'root', 'bizzindexcom' and 'bizzindex' and none works.

i changed the password per your instructions.

@bizzindexcom I'm sorry to hear you're still having trouble. What's the error message that you are seeing when the login fails?

Hey everyone, I wanted to provide one more update on this issue:

Linode was able to implement a fix that can correct this issue automatically if you have the Network Helper enabled. Simply reboot the Linode, and the correct settings should go through automatically.

If you've chosen to disable Network Helper intentionally, and prefer to use a manual/static configuration, the steps outlined above still do correct the issue.

Hey everyone,

CentOS 8

1- Deactivate "Auto-configure networking in Filesystem/Boot Helpers" to prevent Linode overwriting your new configuration.

2- Edit ifcfg-eth0

nano /etc/sysconfig/network-scripts/ifcfg-eth0

Replace with
Add "NETWORKING=yes" (replace with your Ip)


Or run this (replace with your Ip):

echo "NETWORKING=yes" >> /etc/sysconfig/network-scripts/ifcfg-eth0
echo "" >> /etc/sysconfig/network-scripts/ifcfg-eth0

3- Reboot


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct