Squid Proxy IPv6 Geo Location

I am running Squid Proxy on my Linode because we have a customer who needs to be considered coming from the United Kingdom when visiting the web. All works well, except that Google Maps thinks I'm in Kansas. Clearly, this is defeating the purpose of the proxy. Upon further investigation, it appears that various geologication databases thinks our Linode ipv6 address is in different places. I'm not sure what source Google uses for its location, but it thinks I'm in Kansas. If I go to maps.google.com and type in "restaurant" it shows me stuff close to where it thinks I am.

I need Google to think I'm in the UK, what can I do to resolve this (P.S. Disabling IPv6 is not a solution).

1 Reply

It appears that your IPv6 configuration may still be allowing observation of some of the vpn's endpoints. You may want to review your Squid Proxy configuration:

https://wiki.squid-cache.org/Features/IPv6#How_do_I_setup_squid.conf_for_IPv6.3F
http://www.squid-cache.org/Doc/config/location_rewrite_program/

Google uses w3C GeolocationAPI as do most browsers, so you may want to disable geolocation to keep those endpoints from being observed at all:

https://www.ivpn.net/knowledgebase/150/My-real-location-is-detected-when-connected-to-VPN-How-to-disable-geolocation.html

If you have more information to share, we're happy to try and offer more guidance!

Reply

Please enter an answer
Tips:

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct