Lish connects to the wrong server--stuck screen session?

Lish is connecting to the wrong server. Probably this is a stuck screen session because I used Lish to connect to a server in the wrong datacenter:

ssh -t [email protected] server-in-fremont

Then, I connected to a server that is in Newark:

ssh -t [email protected] server-in-newark

And now it is stuck on the first server I connected to in Fremont, and I can only log into the Fremont server.

Oddly, I can connect to other servers in Newark just fine:

ssh -t [email protected] different-server-in-newark

works. It is only stuck on the one server I connected to after the server in Fremont.

I tried typing kill on the Newark Lish server to kill the screen session to no avail:

[[email protected] lish]# kill

I'm guessing support will have to go on that server and kill the stuck screen session.

Oh, and oddly Glish does not have this problem, it connects directly to the correct server. Weblish and SSH connect to the wrong server.

P.S. Please allow line wrapping in Lish.

2 Replies

It's likely that the blank screen is just what the Linode is showing when you connect to it via Lish, rather than Lish being stuck or broken. You can use Lish to connect to any of your Linodes from any datacenter. For example, if you connect to lish-newark.linode.com but have a Linode in Dallas, you can still view that Linode's Lish console even though you're connected via Newark. It does slow the connection down a bit, however, since it has to route through Newark before reaching your computer.

If Lish isn't working for a Linode it may be that the Linode's unresponsive, or that there's just nothing to display. I'd recommend trying to press 'enter' on a blank Lish screen to see if the login prompt comes up. If it doesn't, try rebooting the Linode. If things still don't look right, open a ticket and myself or another member of the Support team will be happy to help.

Thanks for the response. I logged into the server directly via SSH without Lish, and then terminated the lish process (or perhaps the associated SSH process) using kill -9. I saw the process when I ran "ps aux" and saw it was connected to the fremont server. Now lish works on the newark server no problem.

The server was running because as mentioned I was able to connect directly with SSH. Also the screen connected to fremont was responsive. Lish was stuck.

Reply

Please enter an answer
Tips:

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct