LongView install trouble on Debian buster

Trying to install LongView from Linode Manager - in Debian Buster

Automatic process fails:

curl -s https://lv.linode.com/***ID copied from Linode Manager*** | sudo bash
Invalid Installer Session
Please see the Longview details page to start a new session
OR if you would like to install Longview manually please see:
https://linode.com/docs/platform/longview/longview/#manual-installation-with-yum-or-apt

OK, followed these steps from the manual:

1 - Created /etc/linode
2 - Created /etc/linode/longview.key
3 - Fetched https://apt-longview.linode.com/linode.gpg
4 - Moved linode.gpg into /etc/apt/gpg.trusted.d
5 - Created linode.list in /etc/apt/sources.list.d:
deb http://apt-longview.linode.com/ buster main

Now:

apt-get update

fails:

Get:3 http://apt-longview.linode.com buster InRelease [3,241 B]            
Err:3 http://apt-longview.linode.com buster InRelease                      
  The following signatures were invalid: D12F8D2C47B4A16917C9A040BED67E64325A043E
Reading package lists... Done
W: GPG error: http://apt-longview.linode.com buster InRelease: The following signatures were invalid: D12F8D2C47B4A16917C9A040BED67E64325A043E
E: The repository 'http://apt-longview.linode.com buster InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Checking the keys - the linode key is imported:

apt-key list
....
....
pub   rsa4096 2013-02-07 [SC]
      D12F 8D2C 47B4 A169 17C9  A040 BED6 7E64 325A 043E
uid           [ unknown] Linode, LLC <[email protected]>
....
/etc/apt/trusted.gpg.d/linode.gpg
---------------------------------
pub   rsa4096 2013-02-07 [SC]
      D12F 8D2C 47B4 A169 17C9  A040 BED6 7E64 325A 043E
uid           [ unknown] Linode, LLC <[email protected]>

The key is listed twice, I assume first "instance" was added by Linode early on during node creation, and the second was just now added by me into trusted.gpg.d.

But in any case the signing key is there.

Am I doing something wrong or is there an issue on Linode's side?

6 Replies

Tried to edit the linode.list repo file to change the distro name to Ubuntu's - xenial, bionic, cosmic all worked, no signing errors from apt-get update.

But any Debian codename - wheezy, jessie, buster - produces the above GPG error.

And so - looks like Debian repos are not properly signed (while Ubuntu repos are)?

Thanks for letting us know. I'll make sure we get the signatures fixed for the other versions, but for now Debian 9 'stretch' works if you'd like to use it. I've confirmed it on my own Linode, and the same version of Longview that works on Debian 9 will likely work on Debian 10 with no or minimal changes needed.

Debian 9 'stretch' works

Yes indeed. Thank you. Not sure why I didn't think to try it.

Any updates on this? Buster is now officially released

@wbagdon - I'll check on this for you. Thanks for following up.

@wbagdon - I confirmed the packages were updated for Debian 10, so you should be good to go with this.

Reply

Please enter an answer
Tips:

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct