SSH & Console is not working

After MDS patch, I can't connect through SSH, showing the message "ssh: connect to host 176..10.* port 225: Operation timed out"


console is not working properly, this is the out put of the console when we open.

Checking filesystems
Checking all file systems.
[/sbin/fsck.ext3 (1) -- /bin] fsck.ext3 -a /dev/sda
/dev/sda: clean, 158542/3112960 files, 5318107/12451840 blocks
[ OK ]
Remounting root filesystem in read-write mode: EXT4-fs (sda): re-mounted. Optso
[ OK ]
Mounting local filesystems: [ OK ]
Enabling local filesystem quotas: [ OK ]
/etc/rc.d/rc.sysinit: line 553: cat: command not found
/etc/rc.d/rc.sysinit: line 558: chmod: command not found
/etc/rc.d/rc.sysinit: line 612: /bin/rm: No such file or directory
/etc/rc.d/rc.sysinit: line 613: find: command not found
/etc/rc.d/rc.sysinit: line 621: /bin/touch: No such file or directory
/etc/rc.d/rc.sysinit: line 617: plymouth: command not found
/etc/rc.d/rc.sysinit: line 622: chgrp: command not found
/etc/rc.d/rc.sysinit: line 623: chmod: command not found
/etc/rc.d/rc.sysinit: line 634: /bin/rm: No such file or directory
/etc/rc.d/rc.sysinit: line 635: /bin/rm: No such file or directory
/etc/rc.d/rc.sysinit: line 642: chown: command not found
Enabling /etc/fstab swaps: Adding 524284k swap on /dev/sdb. Priority:-2 extenS
[ OK ]
/etc/rc.d/rc.sysinit: line 676: mv: command not found
/etc/rc.d/rc.sysinit: line 677: dmesg: command not found
/etc/rc.d/rc.sysinit: line 682: plymouth: command not found
init: Failed to spawn rcS post-stop process: unable to execute: No such file ory
init: Failed to spawn readahead-disable-services main process: unable to executy

3 Replies

Hey there,

We recommend booting your Linode into Rescue Mode and running a Filesystem Check to clear any errors that might be impacting your init files.

When the errors have been cleared, while still in Rescue Mode, mount your disks to review and if necessary update the permissions on your /etc/rc.d/rc.sysinit file.

Finally, reboot normally and let us know if that cleared the issue. If not, you can provide the new errors here or feel free to open a ticket.

We hope that helps.

Tara T
Linode Support Team

Problem is not solved. Can you give correct permission for /etc/rc.d files

@bmp If you're still having issues with that, it may be best to open a Support ticket. Since the IP address has been censored, I'm guessing you're not comfortable sharing it in a public setting like this, which is fine. By opening a ticket, Support could take a more specific look at your Linode.

That said, permissions for files and directories are not set by Linode, but by the users set up on the Linode itself. Have you tried adding sudo in front of any commands that are returning a response about not having permissions?


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct