Why am I seeing reboots after disabling SELinux?

Linode Staff

I noticed Lassie watchdog reboots on my Linode after I disabled SELinux. Why is this happening?

1 Reply

Linode Staff

When you disable or otherwise change the enforcement mode of SELinux, the application has to relabel the filesystem on your Linode. After the relabeling is complete, your Linode reboots automatically via Lassie, our watchdog service that reboots your Linode if it is unexpectedly powered off. When SELinux finishes relabeling the files, it shuts down your server to save the changes. Lassie then recognizes that your Linode is off without being initiated by you, so it reboots your server.

If SELinux was successfully disabled you should be able to see that by running sestatus. If you see a different mode when you run sestatus, or if you had to re-enable SELinux to get your Linode to boot up, that may indicate a configuration error. There's a guide available on Changing SELinux Modes that may be helpful also :)

Reply

Please enter an answer
Tips:

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct