Why can't I create a snapshot backup?

Linode Staff

I have Backups enabled on my Linode and when I tried to create a snapshot this morning, it failed. Then I tried again and it said a backup is in progress. What's going on?

5 Replies

Linode's Backups Service operates in four general "time slots": daily, weekly, biweekly, and snapshot on demand. While the Backups Service is intended to be friendly to use, there are a few snags that can cause the error you're seeing.

1.) Attempting a snapshot while another backup is running

  • This is most commonly seen when a snapshot is attempted while the daily backup is running. Both backups cannot occur at the same time, so the snapshot attempt gets "stuck" in pending status and must be manually deleted by Linode.

2.) A prior backup has gotten "stuck" during processing

  • The cause is less specific, but the result is the same: both backups can't happen at the same time, and your snapshot fails.

In both instances, you may see the snapshot backup attempt to process before failing. This is because the snapshot request was issued but can't be completed, so the attempt holds an in-between status of "pending" instead.

Currently, we recommend that you avoid this scenario by setting your daily backups time slot to a time frame where you are unlikely to be using your Linode. Alternatively, you can verify that your Linode's backup has already completed for the day by viewing the Backups tab for your Linode in the Cloud Manager. We understand that checking the time slot may not be your project's top priority, so if you do run into this error, don't worry! Just open a ticket with Linode Support and we'll take care of fixing the stuck process.

Mine is broken also. Must be a backend problem. I have had more problems with this service then I would like.

Hi @Brian - We apologize for the inconvenience and trouble this may have caused. I was able to locate the ticket in which you were discussing this with one of our Backup Admins. I reached out to the Admin to get some more details on this and just replied to your ticket. Can you take a look at the ticket and let us know if you need anything further? Thanks!

Thanks I replied that it is broken again. Just trying to get an idea if this is common for other people or not. Mine has broken numerous times over the years.

I have the same problem today, opened a ticket, waiting for reply.


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct