Black screen with Weblish using upstream kernel (Glish works)

So, the title sums it up. I booted up using a upstream kernel image (5.2 Debian10), and everything is working fine, Glish works but not Weblish. Weblish just blinks some prompt information that fade too quickly giving me a black screen where keyboard doesn't work. After digging a bit I got this info:

Linode Lish Console
[*] Wed Aug 28 11:14:59 EDT 2019
[*] Linode Shell (lish) Console starting...
[*] [screen is terminating]

I think this [screen is terminating] is a default message of GNU screen, that is terminating before the prompt spawns for some reason… Any clues?

2 Replies

If you're using a customized upstream kernel, you may need to make the configuration changes detailed here for Lish access. Namely, update these settings in your /etc/default/grub file:

GRUB_SERIAL_COMMAND="serial --speed=19200 --unit=0 --word=8 --parity=no --stop=1"

Then, apply these changes:


You may need to reboot your Linode as well.

Otherwise, you may find our documentation on Lish helpful as well: Using the Linode Shell (Lish)

Hope this helps!

I totally missed that point in the docs (shame on me).
Everything working fine now, Thanks bbigger.


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct