My domains all recently "refused to connect" to my linode. Any idea why?

Even visiting my static IP says "refused to connect" in my Chrome browser. F.e., visiting, says

This site can’t be reached refused to connect.

However, my Linode is still up and running. I can SSH into it too. Any idea why out of nowhere, all domains, and even the IP say "refused to connect" in my browser?

Note, I haven't changed anything on my Linode. It just randomly started doing this.

3 Replies

Well, restarting the linode worked. But any idea what could cause it to suddenly refuse all connections?

I'm glad to hear restarting it worked! That's the first thing I was going to suggest.

There are services that could have made temporary changes to your Linode's network configuration or firewall rules. Is it possible that something such as fail2ban blocked your local IP address temporarily? Other than that, it's possible that an automatic update made changes, though that's just speculation without knowing more about your particular setup.

[@mjones] (/community/user/mjones) I literally haven't changed anything on this Linode for a loooooong time. I haven't set anything up to block connections. I have services that have been running and are a few years old, but nothing new.

Could it have been hacked?


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct