How to create a correct txt record for DKIM with Google Apps

I've read some other threads on this, for example:


But I'm apparently still doing something wrong. After giving it several days to propagate, I attempt to Start Authentication in Google Apps and get the generic error that says you either haven't waited 48 hours yet or your DNS record isn't correct.

So I think my DNS record is probably not right.

In the new (as of earlier this year) interface, the Linode DNS editor has a field for Hostname: in that, I have selector1._domainkey. I tried adding the domain name ( but the interface removes it when I save the form.

In the Value field, I have v=DKIM1; k=rsa; p=LongStringIgotFromGoogleApps…

I'm guessing the problem is that I haven't got the right value in the Hostname field, but it's not clear to me what goes there.

(Edit: I also tried but, again, the interface strips off everything after "_domainkey") when I save the form.

2 Replies

The record name (hostname field) must match what you told Google Apps you were going to use as the selector. For example, if you told Google Apps your selector is google (which is what I use), then the hostname field needs to be google._domainkey. The manager (both Cloud and Classic) will remove the domain name if it exists in the hostname field as the last part, as all records are already relative to the domain name. Also double check that you copied the entire value; the string after p= should start with MIIB and end with AQAB.

That's perfect, thanks! I just needed google in front of ._domainkey, I'm pretty sure. Will probably know for sure in a few hours.

Edit: verified.
Thanks again.


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct