SSL Certificate setup issue

I purchased wildcard SSL from SSLS.com

Followed their instructions of placing Activate text file in ../.well-known/pki-validation folder on website

SSLS.com indicates the certificate is confirmed and active.

This is a Wordpress site so under Settings > General I changed site location and URL from http://… To https://..

After about 12 hours the SSL still has not taken hold. When I type in https://MyDomainName.com I get an ERR_CONNECTION_REFUSED message

If I type in http://MyDomainName.com the site will come up as unsecure, but of course, if I type in http://MyDomainName.com/wp-admin I get connection refused because of settings changed.

Using Debian 9

Searching through the community here I see others with a similar issue and most have solutions giving a link to a page that now only gives a 404 error.

2 Replies

Linode Staff

If you are getting an "ERR_CONNECTION_REFUSED" message when navigating to your site when using HTTPS, this usually means that the web server is either not listening or refusing connections on port 443.

If you haven't set up a firewall rule to allow traffic on port 443, we have excellent guides configuring firewall rules with IPTables here:

Control Network Traffic with iptables

As well as guides on a few common "wrapper" programs like UFW or FirewallD here:

How to Configure a Firewall with UFW
How to Configure a Firewall with FirewallD on CentOS

Once you've opened port 443, you'll need to upload your certificate and key files to your server and configure Apache to listen for connections on port 443 and serve the certificate. Doing so is as simple as adding a few lines of VirtualHost directives to your website's configuration page after you've uploaded your certificate. We have an guide on setting up SSL certificates with Apache here:

SSL Certificates with Apache on Debian & Ubuntu

Once you've set up the certificates and configured Apache and restarted the service, you should be all set and see the valid certificate when navigating to your website via HTTPS at https://mysite.tld

As your website is developed in WordPress. So to activate SSL Certificate on your website, you have to install "Really Simple SSL" wordpress plugin in your dashboard.

This plugin will activate SSL on your website and after activation of SSL, your website will be automatically redirected and opened with https with secure padlock icon.

Reply

Please enter an answer
Tips:

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct