How to "fix" Gentoo now that devfs has gone away

Linode Staff

If you're running "Latest 2.6" kernel, you will notice upon reboot that devfs has been removed from Linux. You'll get an error like:

* Remounting root filesystem read-only (if necessary)... [ ok ]
* Checking root filesystem...fsck.ext3: No such file or directory while trying to open /dev/ubd/0
The superblock could not be read or does not describe a correct ext2
filesystem. If the device is valid and it really contains an ext2
filesystem (and not swap or ufs or something else), then the superblock
is corrupt, and you might try running e2fsck with an alternate superblock:
e2fsck -b 8193 <device>* Filesystem couldn't be fixed :(
[ !! ]</device> 

Here's how to fix this:

1) Edit your configuration profile and enable the "init=/bin/bash" radio box. Save.

2) Boot your Linode

3) Connect with Lish

4) At the root prompt, run: "mount -o remount,rw /"

5) Edit /etc/fstab and change "/dev/ubd/0" to /dev/ubda, and "/dev/ubd/1" to /dev/ubdb, and so on.

6) Change your configuration profile back to the normal run level

7) Reboot.


0 Replies


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct