Why can't I connect to RunCloud?

I installed RunCloud using Ubuntu 18.04, but it's not working properly. Only port 22 is open.

1 Reply

Hello,

Running the nMap command on your Linode's IP address is the best method to confirm all of the following ports are open: 22/tcp (SSH), 80/tcp (HTTP), 443/tcp (HTTPS), and 34210/tcp (RunCloud Communication Port)

According to a Runcloud Blog Post you have to open all of the ports mentioned above. Because you mentioned that only port 22 is open and the rest of of the required ports are closed, I recommend using Uncomplicated Firewall (UFW) to simplify the management of your firewall rules. Here are some commands for opening up ports via UFW.

sudo apt-get install ufw
sudo ufw allow ssh
sudo ufw allow http
sudo ufw allow 443
sudo ufw allow 34210
sudo ufw enable

Take a look at the blog post, it has detailed instructions for installing Runcloud and securing your server.

We also offer a guide on How to Configure a Firewall with UFW.

Reply

Please enter an answer
Tips:

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct