Anybody else having problems with YouTube's API for oEmbed data?

had a large number of clients complaining they couldn't embed YouTube videos across our Linode hosted sites. Similar sites on DO and AWS seem to be fine.

Spotted a couple of people on Twitter who also spotted issues on Friday with the London and Atlanta data centres. Is it possible that YouTube could have block API access for all Linodes?

Thanks
James

10 Replies

Linode Staff

Hey there James,

Thanks for reaching out! We're aware of this issue affecting sites hosted in Atlanta and London, and are reaching out to Google for assistance in resolving this -- we'll be sure to share any additional information as we receive it. Thanks for your patience here, it's greatly appreciated.

All the best,
Chris
Linode Support Team

Is there any update on this? I've got a Linode in Atlanta and am suffering the same problem. I first checked to make sure my actual Linode wasn't requesting anything to Google. I ran monitoring on the network for 24 hours and no requests were made, so apparently it's associated with the IPv6 block. Right now it's causing problems with my Wordpress site and accessing YouTube's OEmbed data.

Thanks!

@hollyit: We're currently working on resolving this with Google, but in the meantime this workaround for Wordpress might help.

I have the same problem since November 15th, server in London.

Thanks @jyoo. I actually ended up solving it by disabling IPv6 on my Linode until you guys can get this worked out with Google.

Hi there,

I'm having the same issue across Linodes in London. I've tried the workaround, but can only get it to work on the backend(!). Any news on this being fixed - it's pretty important for me and took quite a while to narrow it down to a Linode issue!

Cheers
Andy

Fixed by Linode & Google.
Just recently I noticed that it is working again. :)

@Eon1025 We're are awaiting a resolution on this issue, but we've identified a workaround that may be of use. It's outlined in the below Community site post.

I have the same problem with my linode which is hosted in Frankfurt, Germany.

I found the fix to the problem thanks to rdaniels who posted it above (just edit your functions.php in your theme folder within wp-content to apply):
https://www.linode.com/community/questions/19293/youtube-embed-issues-in-london-and-atlanta#answer-70826

QUOTE WITH THE WORKING FIX BELOW:

Right now, we're operating under the assumption that Google is blocking a /64 pool since our affected customers are all falling within that pool.

While we wait for a response from Google, we've come up with a couple of workarounds which should work. The first, and easiest solution, is to add a few lines to the bottom of functions.php which will force cURL requests to go over IPv4:

add_action( 'http_api_curl', function( $curl_handle ) {
curl_setopt( $curl_handle, CURLOPT_IPRESOLVE, CURL_IPRESOLVE_V4 );
});

Another step that can be taken is for us to assign a /64 pool to the affected Linode. It would need to be configured from the customer end in order to use an IP from the pool, which is why we recommend the simpler first option.

It would be nevertheless very nice if this problem could be solved by linode and Google. This error is very hard to find a solution to, as there is many people complaining about this and to find out that the problem is Google somehow blocking Linodes from embedding YouTube videos is very hard to fathom.

Reply

Please enter an answer
Tips:

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct