Outgoing email from mail client failing

I can log into my new Linode email server with Thunderbird from my laptop, and view incoming emails.

I cannot send emails.

The error message I am now getting is the following:

Sending of the message failed.
The message could not be sent because the connection to Outgoing server (SMTP) adonax.com timed out. Try again.

NOTE: I had previously gotten a message about the connection to the Outgoing server failing:

The message could not be sent because connecting to Outgoing server (SMTP) adonax.adonax.com failed. The server may be unavailable or is refusing SMTP connections. Please verify that your Outgoing server (SMTP) settings are correct and try again.

I suspect this earlier message might have been because I had "mylinodeservername.mydomain.com" in the Thunderbird SMTP "Server name" field, instead of "mydomain.com". The name "mydomain.com" is what is in the IMAP settings "Server Name" field in the Thunderbird application and is working successfully.

Is "timing out" a step better than "failing to connect"?

Following are some of the things I've tried or checked.

1) I made a ticket to Linode staff in order to get clearance to send emails, and was told this has been set up and that my A, AAAA, rIP, and other settings look good.

2) I've made sure that the settings on Thunderbird use the same server and user name, for both the incoming and outgoing functions. (See note above.)

3) I have confirmed that port 465 is available.

4) I've double-checked that the same .pem files are being referenced in both postfix/main.cf and dovecot/conf.d/10-ssl.conf

I've added verbose debugging to both dovecot and postfix. I'm not clear on how to interpret the Postfix verbose log, but I think that it is failing to get a match on the sasl authentication steps and proceeds to try matching the IP of my laptop. This of course fails as it should (from main.cf):

smtpd_recipient_restrictions = permit_sasl_authenticated, permit_mynetworks, reject_unauth_destination

If helpful, I can show the verbose log readout from Postfix. The normal readout of an attempt follows:

Dec 17 12:20:09 adonax postfix/smtpd[9127]: connect from 108-216-159-9.lightspeed.sntcca.sbcglobal.net[]
Dec 17 12:21:49 adonax postfix/smtpd[9127]: lost connection after CONNECT from 108-216-159-9.lightspeed.sntcca.sbcglobal.net[]
Dec 17 12:21:49 adonax postfix/smtpd[9127]: disconnect from 108-216-159-9.lightspeed.sntcca.sbcglobal.net[] commands=0/0

The verbose log listing is something like a couple hundred lines long.

I've tried editing the postfix/master.cf to make sure the "chroot" is set to "n" on the lines that were edited in Step 5 of the SMTP section.

Suggestions? Any ideas what to test in the search for errors?

So close! The setup is almost done.

1 Reply

Holy smokes. I changed the SMTP service from using 465 to 587 and now it works.

I wouldn't have thought to try the alternative port, except for rereading Running a Mail Server


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct