How do I fix system issues after upgrade to Centos 7.7

After applying the update to Centos 7.7 from 7.6 I am experiencing sluggishness at the terminal and high cpu utilization by ksoftirqd. I am running the latest 64-bit (5.3.11-x86_64-linode131) kernel.

1 Reply

Hey there,

A few things could cause the ksoftirqd to eat up all the CPU. It could be a host problem that happened at the same time you upgraded the Linode or a kernel issue.

You can check for host issues by running the following commands:

 iostat 1 10

 vmstat 1 20

In the outputs, we are looking at the steal column. This lets us know if your neighbors are using more of their shared resources than what allotted to them.

In a shared environment, there's always going to be some steal. But as it approaches 15%, you will start to see some latency. If you see 30%, there's enough latency that it is negatively affecting your Linode enough to time out or become unresponsive. If you see steal around or above 15%, copy-paste the output into a Support Ticket. We will try to find the quickest resolution for you.

Also, the recommended kernel for CentOS 7 is Grub. You may want to try and switch it instead of using our kernel. For your quick reference, I added a link to our guide explaining how.

How to Change your Linode's Kernel

Make sure to check the caveats section if you enabled Selinux on the Linode.

If you run into any problems, feel free to open a Support Ticket. We'd be happy to check on things for you.


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct