Why is CentOS booting to the GRUB menu?

Linode Staff

I ran some updates on my CentOS Linode, and at reboot I'm now presented with a GRUB menu. It used to automatically boot to the first option, but now it seems to be waiting for me to choose a kernel version before booting.

2 Replies

It seems that a recent update in CentOS has been putting some users at the GRUB menu on boot. The fix I've seen is to select the first option to boot the latest kernel present on your system, then run the following commands and reboot your Linode:

sudo grub2-set-default 0
sudo grub2-mkconfig -o /boot/grub/grub.cfg

It should then boot normally and to the latest kernel, as it always did before.


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct