One-Click - WordPress asking for database details

Linode Staff

When I install WordPress with One-Click Apps, it is asking for database connection details, what do I enter?

8 Replies

I'm sorry to hear that you are experiencing difficulties while setting up your WordPress site.

If you are seeing the page that is asking for database connection details it usually would mean that you attempted to login before the One-Click app finished its setup in the background. You may want to wait a couple of minutes before attempting to login.

If you attempt to login to the WordPress site while the setup process is in progress, you may see your server in various stages of provisioning. For example, I setup a WordPress site in an attempt to reproduce this, and while browsing the site at various times while it was getting setup, I saw variously:

  • No Response
  • A default Apache web site
  • A default WordPress Site
  • A customized WordPress Site

You may just need to go back to the main page and try to login again.
If you continue to see the connection details page, logging in too early may have interfered with the setup process and you may want to retry the One-Click setup again.

I deleted Linode 5 times and repeated same process again and again and also waited for a day. but its still asking for the database details like when we install wordpress manually.

I dont know what are the db name and where to find the details.

Please help me.

You need to create the database yourself before you start WP installation:

Write down the details (db name, password, etc) when you get done and use those in the WP installation.

-- sw

I think one click installer should not have these options ?? Right ?

I dunno. You'll have to ask the author… That wasn't your original question.

-- sw

I dunno. You'll have to ask the author… That wasn't your original question.

-- sw

Linode Staff

I just deployed some WordPress instances to see if I could reproduce this issue, and I think that the problem may be related to the way our One-Click Application handles special character input in the "WordPress - Latest Options" of the OCA deployment.

I was able to deploy a WordPress OCA Linode and visit the default landing page just fine when using alphanumeric characters for my password fields, but using a password full of special characters (I used a ton of them) brought me to a page that said:

Welcome to WordPress. Before getting started, we need some information on the database. You will need to know the following items before proceeding.

Database name
Database username
Database password
Database host
Table prefix (if you want to run more than one WordPress in a single database)

Since the UDF variables are pulled from the deployment page and inserted to a Linux shell script, it is likely that lack of input validation will allow certain characters to break the script. I can't say if or when this is will be corrected, but I'd be willing to bet you'll be able to deploy without trouble if you redeploy without characters that may escape the UDF. (likely " and/or >)

If you'd like to see exactly what our One-Click App does, you can find it here.

Thank you for the guide.
I fixed it by your instructions. Yes, I was using very strong passwords with the helps of a password generator site. Now after your suggestion, I excluded Ambiguous Characters from passwords but still using special characters on my passwords and it solved the problem. So its the problem of very strong passwords.
I am really sorry that it takes your effort to find out the solution but I didn't found out by myself that's why I created a new topic and support ticket.
I also want to know how can I create multiple wordpress installewrs and setup domain for them on a single linode? It is not related to this post but its my next question. Should I open a new topic for this?
Thank you very much for solving my problem.
I really appreciate your time and effort. Linode is awesome and cheap at the same time. <3 <3 <3
Thank you!:)


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct