Wordpress mail issue

Linode Staff

I've had the email restrictions removed from my Linode, but I'm receiving this error when sending a test email with my WP Mail plugin:

PHPMailer was able to connect to SMTP server but failed while trying to send an email.

How do I correct this so I can send mail?

1 Reply

I found a Wordpress Support post about this error, which includes a possible resolution. From that article:

Checking the “Force From Email” box in the WP Mail SMTP settings seems to have resolved this issue.

I wasn't able to find clear instructions on how to enable this within the Wordpress GUI, but I was able to find this Wordpress Support post, which talks about changing the setting directly in wp-config.php. From that article:

Thank you so much for your quick response today!

I’ve added:

define('WPMS_MAIL_FROM_FORCE', 'true');

to wp-config.php

In the UI on options-general.php?page=wp-mail-smtp the checkbox becomes greyed out, but it does not show as “checked”

However, the sending address is correctly forced to my defined sending email address. Solved for me!

You can update that file by connecting to your Linode via SSH or LISH, and using any text editor, such as nano or vi.


Please enter an answer

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct