Fail no connect to SMTP server from Nanode

Hello everyone!

I'm trying to setup a platform called Loomio. So far, I have been able to get it up and running. Setup is done through Docker. In order for the platform to work, it needs and SMTP server.

I have access to an SMTP server on another machine. I know it works because it has been in production for a very long time. However, I have not been able make a connection to the SMTP server.

In order to troubleshoot the problem I have been working with SWAKS.

I tried sending a test message from personal computer, and I know all the settings work, because I have received the email correctly. I have contacted the host of the SMTP server, and they have also confirmed that they can send the receive sucesfully.

However, when I login to the SSH terminal on the nanode, and try to run the exact same command, as follows:

[email protected]:~$ sudo ./swaks --to randomemail@example.com --from "[email protected]" --auth LOGIN --auth-user "[email protected]" --auth-password "RANDOMPASSWORD" --server mail.associacaomusicalsuzuki.com.br -tlsc

I get:

=== Trying mail.associacaomusicalsuzuki.com.br:465…
*** Error connecting to mail.associacaomusicalsuzuki.com.br:465:
*** IO::Socket::INET: connect: timeout

I'm wondering if I have made any mistakes in configuring the NANODE, or if there is something I overlooked. Why can I not send this test message from the NANODE, but can from my personal computer?

Help would be appreciated!

Thank you very much!
Fabio.

4 Replies

Linode blocks outbound mail for accounts after 2019Nov5 until you do a few things and put in a ticket.

Reference: https://www.linode.com/docs/email/running-a-mail-server/#sending-email-on-linode

Relevant text from it:

Sending Email on Linode

In an effort to fight spam, Linode restricts outbound connections on ports 25, 465, and 587 on all Linodes for new accounts created after November 5th, 2019.

If you have a need to send mail from your Linode, we ask that you first configure (1) valid DNS A records and (2) rDNS records for any Linodes that you plan to use to send mail. Then, open a Support ticket from the Linode Manager – we’ll ask you to provide the name of the Linode(s) that will be used for mailing.

Once you’ve completed those steps and provided that information, our Support team will be happy to review your request.

Solved! Thanks for the info!

Why cloud.linode.com does not show on the network config panel of the affected Linode that outgoing SMTP is blocked?

It could have saved me hours of hopeless (and pointless) configuration attempts!

Please, please show this information on the control panel at a prominent place, so people don't spend time on it.

Thank you!

@ViktorThank you for sharing your feelings with us. We really take our customer's feedback seriously and our team is currently discussing the best way to communicate SMTP restrictions better. I've also made sure to add your voice to our internal tracker for this change.

Please, feel free to pass along any feedback you have either here or to [email protected]

Reply

Please enter an answer
Tips:

You can mention users to notify them: @username

You can use Markdown to format your question. For more examples see the Markdown Cheatsheet.

> I’m a blockquote.

I’m a blockquote.

[I'm a link] (https://www.google.com)

I'm a link

**I am bold** I am bold

*I am italicized* I am italicized

Community Code of Conduct